summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Adam Chlipala <adamc@hcoop.net>2010-02-11 11:29:36 -0500
committerGravatar Adam Chlipala <adamc@hcoop.net>2010-02-11 11:29:36 -0500
commit3e839544936e8a9456d798d5f315991f976f6a53 (patch)
tree5000f3e2d50b46f7a0cb84380be457aba0fe2717 /configure.ac
parentabe2d7ed6e151579cd6f13fd0ce92e29bb83a23d (diff)
'configure' checks for libmhash and MLton
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1d6613a1..d65d6e4c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5,6 +5,30 @@ AC_PROG_CC()
AC_PROG_LIBTOOL()
AC_CONFIG_MACRO_DIR([m4])
+AC_CHECK_LIB(mhash, mhash_get_block_size, [], [echo "You must install libmhash."; exit 1])
+AC_CHECK_HEADER([mhash.h], [], [echo "You must install libmhash dev files."; exit 1])
+
+AC_CHECK_PROG(MLTON, mlton, yes, [])
+
+if test [-z $MLTON]; then
+ echo "You must install MLton."
+ exit 1
+fi
+
+AC_CHECK_PROG(MLLEX, mllex, yes, [])
+
+if test [-z $MLLEX]; then
+ echo "You must install MLton (to get mllex)."
+ exit 1
+fi
+
+AC_CHECK_PROG(MLYACC, mlyacc, yes, [])
+
+if test [-z $MLYACC]; then
+ echo "You must install MLton (to get mlyacc)."
+ exit 1
+fi
+
if test [$prefix = "NONE"]; then
prefix=/usr/local
fi