summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
authorGravatar Adam Chlipala <adamc@hcoop.net>2008-11-25 15:57:16 -0500
committerGravatar Adam Chlipala <adamc@hcoop.net>2008-11-25 15:57:16 -0500
commita42fe6be6ba6dcb629a6e522624de6506dd7852e (patch)
treef43f7d0cc86e7897cb9e28540a300e1c877e0efe /Makefile.in
parent940865b04fa534983982b261386a3b1926bd5531 (diff)
Profiling in Makefile
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.in b/Makefile.in
index ff1f4b6a..a12cb59b 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -53,6 +53,10 @@ ifdef DEBUG
MLTON += -const 'Exn.keepHistory true'
endif
+ifdef PROFILE
+ MLTON += -profile $(PROFILE)
+endif
+
bin/urweb: src/urweb.mlb src/*.sig src/*.sml \
src/urweb.mlton.lex.sml \
src/urweb.mlton.grm.sig src/urweb.mlton.grm.sml