summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
authorGravatar Adam Chlipala <adamc@hcoop.net>2008-10-24 17:39:47 -0400
committerGravatar Adam Chlipala <adamc@hcoop.net>2008-10-24 17:39:47 -0400
commit3eb7517cc65f6767fad0f2e2a1984106c40214a5 (patch)
tree61345a5b2556f236fc98b99c08d164520d99b799 /Makefile.in
parentf5aed55553fddedd52105461e49411bb48e34de3 (diff)
Add 'package' make target; add LICENSE
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.in b/Makefile.in
index 66da550e..f85b851c 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -8,7 +8,7 @@ LIB_C := $(LIB)/c
all: smlnj mlton c
-.PHONY: all smlnj mlton c clean install
+.PHONY: all smlnj mlton c clean install package
smlnj: src/urweb.cm
mlton: bin/urweb
@@ -69,3 +69,6 @@ install:
cp include/*.h $(INCLUDE)/
mkdir -p $(SITELISP)
cp src/elisp/*.el $(SITELISP)/
+
+package:
+ hg archive -t tgz -X tests /tmp/urweb.tgz