summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
authorGravatar Adam Chlipala <adamc@hcoop.net>2009-06-23 15:56:04 -0400
committerGravatar Adam Chlipala <adamc@hcoop.net>2009-06-23 15:56:04 -0400
commit32b2d196fc02ca4f9f87574e6da1ffa6c1ea12ab (patch)
tree5c08087fd98403edb3500ac4399ddece25c667ad /Makefile.in
parent1109a4e1c8b10a8f524c1406a4db98eff55b435c (diff)
Initial implementation of protocols in Settings
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.in b/Makefile.in
index 9347e96f..d021aad1 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -13,7 +13,9 @@ all: smlnj mlton c
smlnj: src/urweb.cm
mlton: bin/urweb
-c: lib/c/urweb.o lib/c/request.o lib/c/driver.o
+
+OBJS := urweb request http
+c: $(OBJS:%=lib/c/%.o)
clean:
rm -f src/*.mlton.grm.* src/*.mlton.lex.* \