summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
authorGravatar Adam Chlipala <adamc@hcoop.net>2009-12-31 11:41:57 -0500
committerGravatar Adam Chlipala <adamc@hcoop.net>2009-12-31 11:41:57 -0500
commit21678b3f280cd85961e3354faecc29aab4819de4 (patch)
treebd23d8cf5bd50193307b43173436dee92553e4cd /Makefile.in
parentc0b98201e7415eeada11e08c69264cf165bba50f (diff)
Basis.serialize; separate file for mhash; run transactional finishers in reverse order; set needs_sig properly
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.in b/Makefile.in
index 5016abb3..32e123b4 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -17,7 +17,7 @@ all: smlnj mlton c
smlnj: src/urweb.cm
mlton: bin/urweb
-OBJS := memmem urweb request queue http cgi fastcgi
+OBJS := memmem mhash urweb request queue http cgi fastcgi
SOS := urweb urweb_http urweb_cgi urweb_fastcgi
c: $(OBJS:%=lib/c/%.o) $(SOS:%=lib/c/lib%.so.$(LD_MAJOR).$(LD_MINOR))
@@ -33,7 +33,7 @@ lib/c/%.do: src/c/%.c include/*.h
lib/c/%.o: src/c/%.c include/*.h
gcc -Wimplicit -O3 -I include -c $< -o $@ $(CFLAGS)
-URWEB_OS := memmem urweb queue request
+URWEB_OS := memmem urweb queue request mhash
lib/c/liburweb.so.$(LD_MAJOR).$(LD_MINOR): $(URWEB_OS:%=lib/c/%.do)
gcc -shared -Wl,-soname,liburweb.so.$(LD_MAJOR) -o $@ $^