summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGravatar Benjamin Barenblat <bbaren@google.com>2017-05-02 12:25:32 -0400
committerGravatar Benjamin Barenblat <bbaren@google.com>2017-05-02 12:25:32 -0400
commitecf1d5aea6bdfe93b24af07f07a925eb477d685d (patch)
tree6ed93ee636487c136ec9760f7b05bc9be00b06e8 /Makefile.am
parent680da1afd0b8d2f4b4a6b4ec0ef3bad48d0babde (diff)
Use quiet mode for Ur/Web binaries in tests
Reduce chatter on stdout during `make test` (notably, that introduced by a478380e74c658637c90436c4e78c894f7076f4c) by running test binaries with `-q`.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 33bf4e7c..f0392de0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -123,7 +123,7 @@ test:
bin/urweb -boot -noEmacs -dbms sqlite -db $(TESTDB) -demo /Demo demo
rm -f $(TESTDB)
sqlite3 $(TESTDB) < demo/demo.sql
- demo/demo.exe -a 127.0.0.1 & echo $$! > $(TESTPID)
+ demo/demo.exe -q -a 127.0.0.1 & echo $$! > $(TESTPID)
sleep 1
(curl -s 'http://localhost:8080/Demo/Hello/main' | diff tests/hello.html -) || (kill `cat $(TESTPID)`; echo "Test 'Hello' failed"; /bin/false)
(curl -s 'http://localhost:8080/Demo/Crud1/create?A=1&B=2&C=3&D=4' | diff tests/crud1.html -) || (kill `cat $(TESTPID)`; echo "Test 'Crud1' failed"; /bin/false)
@@ -133,7 +133,7 @@ test:
echo "Running IPv6 tests."; \
rm -f $(TESTDB); \
sqlite3 $(TESTDB) < demo/demo.sql; \
- demo/demo.exe -A ::1 & echo $$! > $(TESTPID); \
+ demo/demo.exe -q -A ::1 & echo $$! > $(TESTPID); \
sleep 1; \
(curl -g -6 -s 'http://[::1]:8080/Demo/Hello/main' | diff tests/hello.html -) || (kill `cat $(TESTPID)`; echo "Test 'Hello' failed"; /bin/false); \
(curl -g -6 -s 'http://[::1]:8080/Demo/Crud1/create?A=1&B=2&C=3&D=4' | diff tests/crud1.html -) || (kill `cat $(TESTPID)`; echo "Test 'Crud1' failed"; /bin/false); \