summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGravatar Artyom Shalkhakov <artyom.shalkhakov@gmail.com>2017-02-02 17:31:31 +0000
committerGravatar Artyom Shalkhakov <artyom.shalkhakov@gmail.com>2017-02-02 17:31:31 +0000
commite36034c2fba0bf2a6f3fbd1a4e0cee2d796a6cc4 (patch)
treeb9b9b7eda5f73eaba7ddd50610f33d02eadb5731 /Makefile.am
parent59454c9766685b381603aaf116bb43a9515dbdba (diff)
Adding: support for Emacs Bg Build mode
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 83a08171..33bf4e7c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,6 +19,7 @@ SUBDIRS = src/c
smlnj: src/urweb.cm xml/entities.sml
mlton: bin/urweb
+mlton-tc: bin/urwebtc
clean-local:
rm -f bin/urweb src/urweb.mlton.* \
@@ -60,6 +61,12 @@ bin/urweb: src/compiler.mlb xml/entities.sml \
src/urweb.mlton.grm.sig src/urweb.mlton.grm.sml
mkdir -p bin
$(MLTON) $(MLTONARGS) -mlb-path-var 'SRC $(abs_srcdir)/src' -mlb-path-var 'BUILD $(abs_builddir)/src' -output $@ $<
+bin/urwebtc: src/compiler.mlb xml/entities.sml \
+ src/urweb.mlb $(srcdir)/src/*.sig $(srcdir)/src/*.sml src/config.sml \
+ src/urweb.mlton.lex.sml \
+ src/urweb.mlton.grm.sig src/urweb.mlton.grm.sml
+ mkdir -p bin
+ $(MLTON) $(MLTONARGS) -prefer-abs-paths true -show-def-use compiler.du -stop tc -mlb-path-var 'SRC $(abs_srcdir)/src' -mlb-path-var 'BUILD $(abs_builddir)/src' -output $@ $<
xml/entities.sml: xml/parse xml/xhtml-lat1.ent xml/xhtml-special.ent xml/xhtml-symbol.ent
$^ > $@