summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGravatar Jason Gross <jgross@mit.edu>2012-12-12 14:47:06 -0500
committerGravatar Jason Gross <jgross@mit.edu>2012-12-12 14:47:06 -0500
commitddeb9c57ed9b292082503aa10ebc942500ac8950 (patch)
treeabd07b9c5f5d1525e872391534112720c157fc9d /Makefile.am
parent87d2e717c0d164759fce1df7d89f25fda8434586 (diff)
Add ./configure MLTONARGS option for MLTON arguments
Named MLTONARGS based on CCARGS.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 7 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index 946fcae6..24b1eca3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,10 +1,11 @@
ACLOCAL_AMFLAGS = -I m4
-BIN = @BIN@
-SRCLIB = @SRCLIB@
-INCLUDE = @INCLUDE@
-SITELISP = @SITELISP@
-VERSION = @VERSION@
+BIN = @BIN@
+SRCLIB = @SRCLIB@
+INCLUDE = @INCLUDE@
+SITELISP = @SITELISP@
+VERSION = @VERSION@
+MLTONARGS = @MLTONARGS@
LIB_UR = $(SRCLIB)/ur
LIB_C = $(SRCLIB)/c
@@ -59,7 +60,7 @@ bin/urweb: xml/entities.sml \
src/compiler.mlb src/urweb.mlb src/*.sig src/*.sml \
src/urweb.mlton.lex.sml \
src/urweb.mlton.grm.sig src/urweb.mlton.grm.sml
- $(MLTON) -output $@ src/compiler.mlb
+ $(MLTON) $(MLTONARGS) -output $@ src/compiler.mlb
xml/entities.sml: xml/parse xml/xhtml-lat1.ent xml/xhtml-special.ent xml/xhtml-symbol.ent
xml/parse >xml/entities.sml