summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGravatar Adam Chlipala <adam@chlipala.net>2011-11-05 15:05:13 -0400
committerGravatar Adam Chlipala <adam@chlipala.net>2011-11-05 15:05:13 -0400
commit954936dd180e34b79baca71e43d55a204dda9594 (patch)
treebb624710b05d07871646fc5a93a9b7014d5874dd /Makefile.am
parent22d36c8605e1d006a379350e28a5f939f7082546 (diff)
Support the full set of XHTML character entities
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 45e7d7e0..42e5d4d7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -21,7 +21,7 @@ mlton: bin/urweb
clean-local:
rm -f src/*.mlton.grm.* src/*.mlton.lex.* \
- src/urweb.cm src/urweb.mlb
+ src/urweb.cm src/urweb.mlb xml/parse xml/entities.sml
rm -rf .cm src/.cm
src/urweb.cm: src/prefix.cm src/sources
@@ -55,11 +55,18 @@ MLTON := mlton
# MLTON += -profile $(PROFILE)
#endif
-bin/urweb: src/compiler.mlb src/urweb.mlb src/*.sig src/*.sml \
+bin/urweb: xml/entities.sml \
+ src/compiler.mlb src/urweb.mlb src/*.sig src/*.sml \
src/urweb.mlton.lex.sml \
src/urweb.mlton.grm.sig src/urweb.mlton.grm.sml
$(MLTON) -output $@ src/compiler.mlb
+xml/entities.sml: xml/parse xml/xhtml-lat1.ent xml/xhtml-special.ent xml/xhtml-symbol.ent
+ xml/parse >xml/entities.sml
+
+xml/parse: xml/parse.sml
+ $(MLTON) xml/parse.sml
+
install-exec-emacs:
if USE_EMACS
mkdir -p $(DESTDIR)$(SITELISP)