summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGravatar Edward Z. Yang <ezyang@mit.edu>2012-05-02 17:17:57 -0400
committerGravatar Edward Z. Yang <ezyang@mit.edu>2012-05-02 17:17:57 -0400
commit5e29700b15fad9e4ccbbea59b8312c53447df01b (patch)
tree91cc80e8e50847ab4c3b37714f133417df65f59a /Makefile.am
parent1ca9408089542b282078cc1b7f3c8aa71659f00c (diff)
Add support for -boot flag, which allows in-tree execution of Ur/Web
The boot flag rewrites most hardcoded paths to point to the build directory, and also forces static compilation. This is convenient for developing Ur/Web, or if you cannot 'sudo make install' Ur/Web. The following changes were made: * Header files were moved to include/urweb instead of include; this lets FFI users point their C_INCLUDE_PATH at this directory at write <urweb/urweb.h>. For internal Ur/Web executables, we simply pass -I$PATH/include/urweb as normal. * Differentiate between LIB and SRCLIB; SRCLIB is Ur and JavaScript source files, while LIB is compiled products from libtool. For in-tree compilation these live in different places. * No longer reference Config for paths; instead use Settings; these settings can be changed dynamically by Compiler.enableBoot () (TODO: add a disableBoot function.) * config.h is now generated directly in include/urweb/config.h, for consistency's sake (especially since it gets installed along with the rest of the headers!) * All of the autotools build products got updated. * The linkStatic field in protocols now only contains the name of the build product, and not the absolute path. Future users have to be careful not to reference the Settings files to early, lest they get an old version (this was the source of two bugs during development of this patch.)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 98d1ca11..77f8f4e2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -82,8 +82,7 @@ install-exec-local-main:
mkdir -p $(DESTDIR)$(LIB_JS)
cp lib/js/*.js $(DESTDIR)$(LIB_JS)/
mkdir -p $(DESTDIR)$(INCLUDE)
- cp config.h $(DESTDIR)$(INCLUDE)/
- cp include/*.h $(DESTDIR)$(INCLUDE)/
+ cp include/urweb/*.h $(DESTDIR)$(INCLUDE)/
install-exec-local: install-exec-local-main install-exec-emacs
-ldconfig