summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGravatar Adam Chlipala <adamc@csail.mit.edu>2016-09-19 15:52:05 -0400
committerGravatar Adam Chlipala <adamc@csail.mit.edu>2016-09-19 15:52:05 -0400
commit3afe16344c02881e4ace9e8965f48154b5225638 (patch)
treef43741351a923e07026e29d35b3a04d76b0adb07 /Makefile.am
parent51edbe25d082a0db06727b25b9a3739d807ae277 (diff)
make test: add extra 'curl' flags to make IPv6 work in Ubuntu 14.04
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 0b9a5957..83a08171 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -128,8 +128,8 @@ test:
sqlite3 $(TESTDB) < demo/demo.sql; \
demo/demo.exe -A ::1 & echo $$! > $(TESTPID); \
sleep 1; \
- (curl -s 'http://[::1]:8080/Demo/Hello/main' | diff tests/hello.html -) || (kill `cat $(TESTPID)`; echo "Test 'Hello' failed"; /bin/false); \
- (curl -s 'http://[::1]:8080/Demo/Crud1/create?A=1&B=2&C=3&D=4' | diff tests/crud1.html -) || (kill `cat $(TESTPID)`; echo "Test 'Crud1' failed"; /bin/false); \
+ (curl -g -6 -s 'http://[::1]:8080/Demo/Hello/main' | diff tests/hello.html -) || (kill `cat $(TESTPID)`; echo "Test 'Hello' failed"; /bin/false); \
+ (curl -g -6 -s 'http://[::1]:8080/Demo/Crud1/create?A=1&B=2&C=3&D=4' | diff tests/crud1.html -) || (kill `cat $(TESTPID)`; echo "Test 'Crud1' failed"; /bin/false); \
kill `cat $(TESTPID)`; \
else \
echo "Skipped IPv6 tests."; \