summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGravatar Benjamin Barenblat <bbaren@mit.edu>2020-05-30 19:49:56 -0400
committerGravatar Benjamin Barenblat <bbaren@mit.edu>2020-05-30 19:49:56 -0400
commitc2f1e1096f602b1cbd4531352f3e1ea6d656a186 (patch)
treeae102982878bb0c31bdfe07209e60bfc14030490 /Makefile.am
parent095c2640aa2070ed4e2765875238d5e6e6673856 (diff)
parent5a0b639dfbd7db9d16c6995f72ba17152a1f362d (diff)
Merge branch 'upstream' into dfsg_clean20200209+dfsgdfsg_clean
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index f0392de0..0aba6781 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -112,9 +112,16 @@ uninstall-local-main:
uninstall-local: uninstall-local-main uninstall-emacs
-EXTRA_DIST = demo doc lib/js lib/ur xml \
+EXTRA_DIST = demo/prose demo/*.urs demo/*.ur demo/*.urp demo/more/prose demo/more/*.urs demo/more/*.ur demo/more/*.urp \
+ doc/Makefile doc/*.tex doc/*.ur doc/LICENSE lib/js \
+ lib/ur/*.urs lib/ur/*.ur xml/parse.sml xml/*.ent \
src/coq src/*.sig src/*.sml src/*.mlb src/config.sml.in src/elisp src/*.cm src/sources src/*.grm src/*.lex \
- CHANGELOG LICENSE urweb.ebuild include/urweb/*.h bin
+ CHANGELOG LICENSE urweb.ebuild include/urweb/*.h tests/*.html
+
+dist-hook:
+ cd src; rm -f urweb.mlton.lex urweb.mlton.grm *.lex.* *.grm.*
+ cd demo; rm -f demo.ur*
+ cd demo/more; rm -f demo.ur*
TESTDB = /tmp/urweb.db
TESTPID = /tmp/urweb.pid