summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Adam Chlipala <adamc@hcoop.net>2008-01-26 10:06:22 -0500
committerGravatar Adam Chlipala <adamc@hcoop.net>2008-01-26 10:06:22 -0500
commit9c27c9d90a3f3593de07658a14581b66d08c8b75 (patch)
tree84551101df757af93ee975470d308bf6badec59c
Initial skeleton
-rw-r--r--.hgignore10
-rw-r--r--Makefile41
-rw-r--r--src/errormsg.sig39
-rw-r--r--src/errormsg.sml39
-rw-r--r--src/laconic.sml59
-rw-r--r--src/main.mlton.sml27
-rw-r--r--src/prefix.cm6
-rw-r--r--src/prefix.mlb5
-rw-r--r--src/sources4
-rw-r--r--src/suffix.mlb1
10 files changed, 231 insertions, 0 deletions
diff --git a/.hgignore b/.hgignore
new file mode 100644
index 00000000..361098b6
--- /dev/null
+++ b/.hgignore
@@ -0,0 +1,10 @@
+syntax: glob
+
+*~
+.cm
+src/.cm
+
+bin/*
+
+src/lacweb.cm
+src/lacweb.mlb
diff --git a/Makefile b/Makefile
new file mode 100644
index 00000000..1705c222
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,41 @@
+all: smlnj mlton
+
+.PHONY: all smlnj mlton clean
+
+smlnj: src/lacweb.cm
+mlton: bin/lacweb
+
+clean:
+ rm -f src/*.mlton.grm.* src/*.mlton.lex.* \
+ src/lacweb.cm src/lacweb.mlb
+ rm -rf .cm src/.cm
+
+src/lacweb.cm: src/prefix.cm src/sources
+ cat src/prefix.cm src/sources \
+ >src/lacweb.cm
+
+src/lacweb.mlb: src/prefix.mlb src/sources src/suffix.mlb
+ cat src/prefix.mlb src/sources src/suffix.mlb \
+ | sed 's/^\(.*\).grm$$/\1.mlton.grm.sig\n\1.mlton.grm.sml/' \
+ | sed 's/^\(.*\).lex$$/\1.mlton.lex.sml/' \
+ >src/lacweb.mlb
+
+%.mlton.lex: %.lex
+ cp $< $@
+%.mlton.grm: %.grm
+ cp $< $@
+
+%.mlton.lex.sml: %.mlton.lex
+ mllex $<
+
+%.mlton.grm.sig %.mlton.grm.sml: %.mlton.grm
+ mlyacc $<
+
+MLTON := mlton
+
+ifdef DEBUG
+ MLTON += -const 'Exn.keepHistory true'
+endif
+
+bin/lacweb: src/lacweb.mlb src/*.sig src/*.sml
+ $(MLTON) -output $@ src/lacweb.mlb
diff --git a/src/errormsg.sig b/src/errormsg.sig
new file mode 100644
index 00000000..0716a3df
--- /dev/null
+++ b/src/errormsg.sig
@@ -0,0 +1,39 @@
+(* Copyright (c) 2008, Adam Chlipala
+ * All rights reserved.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions are met:
+ *
+ * - Redistributions of source code must retain the above copyright notice,
+ * this list of conditions and the following disclaimer.
+ * - Redistributions in binary form must reproduce the above copyright notice,
+ * this list of conditions and the following disclaimer in the documentation
+ * and/or other materials provided with the distribution.
+ * - The names of contributors may not be used to endorse or promote products
+ * derived from this software without specific prior written permission.
+ *
+ * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
+ * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+ * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+ * ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE
+ * LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
+ * CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
+ * SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
+ * INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
+ * CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
+ * ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+ * POSSIBILITY OF SUCH DAMAGE.
+ *)
+
+signature ERROR_MSG = sig
+
+ type pos = {line : int,
+ char : int}
+
+ type span = {file : string,
+ first : pos,
+ last : pos}
+
+ type 'a located = 'a * span
+
+end
diff --git a/src/errormsg.sml b/src/errormsg.sml
new file mode 100644
index 00000000..9f41fff3
--- /dev/null
+++ b/src/errormsg.sml
@@ -0,0 +1,39 @@
+(* Copyright (c) 2008, Adam Chlipala
+ * All rights reserved.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions are met:
+ *
+ * - Redistributions of source code must retain the above copyright notice,
+ * this list of conditions and the following disclaimer.
+ * - Redistributions in binary form must reproduce the above copyright notice,
+ * this list of conditions and the following disclaimer in the documentation
+ * and/or other materials provided with the distribution.
+ * - The names of contributors may not be used to endorse or promote products
+ * derived from this software without specific prior written permission.
+ *
+ * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
+ * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+ * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+ * ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE
+ * LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
+ * CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
+ * SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
+ * INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
+ * CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
+ * ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+ * POSSIBILITY OF SUCH DAMAGE.
+ *)
+
+structure ErrorMsg :> ERROR_MSG = struct
+
+type pos = {line : int,
+ char : int}
+
+type span = {file : string,
+ first : pos,
+ last : pos}
+
+type 'a located = 'a * span
+
+end
diff --git a/src/laconic.sml b/src/laconic.sml
new file mode 100644
index 00000000..eacc7ebc
--- /dev/null
+++ b/src/laconic.sml
@@ -0,0 +1,59 @@
+(* Copyright (c) 2008, Adam Chlipala
+ * All rights reserved.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions are met:
+ *
+ * - Redistributions of source code must retain the above copyright notice,
+ * this list of conditions and the following disclaimer.
+ * - Redistributions in binary form must reproduce the above copyright notice,
+ * this list of conditions and the following disclaimer in the documentation
+ * and/or other materials provided with the distribution.
+ * - The names of contributors may not be used to endorse or promote products
+ * derived from this software without specific prior written permission.
+ *
+ * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
+ * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+ * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+ * ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE
+ * LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
+ * CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
+ * SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
+ * INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
+ * CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
+ * ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+ * POSSIBILITY OF SUCH DAMAGE.
+ *)
+
+structure Laconic = struct
+
+type 'a located = 'a ErrorMsg.located
+
+datatype kind' =
+ KType
+ | KArrow of kind * kind
+ | KName
+ | KRecord of kind
+
+withtype kind = kind' located
+
+datatype con' =
+ CAnnot of con * kind
+
+ | TFun of con * con
+ | TCFun of bool * string option * kind * con
+ | TRecord of con
+
+ | CFvar of string
+ | CBvar of int
+ | CApp of con * con
+ | CAbs of string * kind * con
+
+ | CName of string
+
+ | CRecord of (string * con) list
+ | CConcat of con * con
+
+withtype con = con' located
+
+end
diff --git a/src/main.mlton.sml b/src/main.mlton.sml
new file mode 100644
index 00000000..833f8c11
--- /dev/null
+++ b/src/main.mlton.sml
@@ -0,0 +1,27 @@
+(* Copyright (c) 2008, Adam Chlipala
+ * All rights reserved.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions are met:
+ *
+ * - Redistributions of source code must retain the above copyright notice,
+ * this list of conditions and the following disclaimer.
+ * - Redistributions in binary form must reproduce the above copyright notice,
+ * this list of conditions and the following disclaimer in the documentation
+ * and/or other materials provided with the distribution.
+ * - The names of contributors may not be used to endorse or promote products
+ * derived from this software without specific prior written permission.
+ *
+ * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
+ * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+ * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+ * ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE
+ * LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
+ * CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
+ * SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
+ * INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
+ * CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
+ * ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+ * POSSIBILITY OF SUCH DAMAGE.
+ *)
+
diff --git a/src/prefix.cm b/src/prefix.cm
new file mode 100644
index 00000000..cbd9c651
--- /dev/null
+++ b/src/prefix.cm
@@ -0,0 +1,6 @@
+Group is
+
+$/basis.cm
+$/smlnj-lib.cm
+$/ml-yacc-lib.cm
+$/pp-lib.cm
diff --git a/src/prefix.mlb b/src/prefix.mlb
new file mode 100644
index 00000000..7e47a195
--- /dev/null
+++ b/src/prefix.mlb
@@ -0,0 +1,5 @@
+$(SML_LIB)/basis/basis.mlb
+$(SML_LIB)/smlnj-lib/Util/smlnj-lib.mlb
+$(SML_LIB)/mlyacc-lib/mlyacc-lib.mlb
+$(SML_LIB)/smlnj-lib/PP/pp-lib.mlb
+
diff --git a/src/sources b/src/sources
new file mode 100644
index 00000000..f4bd55b0
--- /dev/null
+++ b/src/sources
@@ -0,0 +1,4 @@
+errormsg.sig
+errormsg.sml
+
+laconic.sml
diff --git a/src/suffix.mlb b/src/suffix.mlb
new file mode 100644
index 00000000..e50b4f49
--- /dev/null
+++ b/src/suffix.mlb
@@ -0,0 +1 @@
+main.mlton.sml