summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Adam Chlipala <adam@chlipala.net>2011-11-27 15:12:44 -0500
committerGravatar Adam Chlipala <adam@chlipala.net>2011-11-27 15:12:44 -0500
commit80e22623aab7b64bda3c923849afa1267e2d6d6e (patch)
treec633eb90fcdf1c941d96e23abcdda5416231b749
parent7ffeb5c51202742f493bd62236db6f3c3489157e (diff)
New release
-rw-r--r--CHANGELOG14
-rwxr-xr-xconfigure22
-rw-r--r--configure.ac4
3 files changed, 27 insertions, 13 deletions
diff --git a/CHANGELOG b/CHANGELOG
index fb7d6704..a1a56ebf 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,4 +1,18 @@
========
+20111127
+========
+
+- Improvements to type inference and error messages
+- New Basis members: ceil, float, null, round, trunc
+- New SQL expression forms: 'IF..THEN..ELSE', 'COALESCE', and 'LIKE'
+- Support for the full set of HTML character entities
+- Client-side versions of some time-related functions
+- New URWEB_PG_CON environment variable
+- Allow arguments for 'con' signature items, not just declarations
+- Bug fixes and performance improvements
+- Tweaks for idiosyncrasies of OS X (like deprecated OpenSSL)
+
+========
20110917
========
diff --git a/configure b/configure
index a21f5f6d..a0424ab0 100755
--- a/configure
+++ b/configure
@@ -1,6 +1,6 @@
#! /bin/sh
# Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.68 for urweb 20110917.
+# Generated by GNU Autoconf 2.68 for urweb 20111127.
#
#
# Copyright (C) 1992, 1993, 1994, 1995, 1996, 1998, 1999, 2000, 2001,
@@ -567,8 +567,8 @@ MAKEFLAGS=
# Identity of this package.
PACKAGE_NAME='urweb'
PACKAGE_TARNAME='urweb'
-PACKAGE_VERSION='20110917'
-PACKAGE_STRING='urweb 20110917'
+PACKAGE_VERSION='20111127'
+PACKAGE_STRING='urweb 20111127'
PACKAGE_BUGREPORT=''
PACKAGE_URL=''
@@ -1305,7 +1305,7 @@ if test "$ac_init_help" = "long"; then
# Omit some internal or obsolete options to make the list less imposing.
# This message is too long to be a string in the A/UX 3.1 sh.
cat <<_ACEOF
-\`configure' configures urweb 20110917 to adapt to many kinds of systems.
+\`configure' configures urweb 20111127 to adapt to many kinds of systems.
Usage: $0 [OPTION]... [VAR=VALUE]...
@@ -1375,7 +1375,7 @@ fi
if test -n "$ac_init_help"; then
case $ac_init_help in
- short | recursive ) echo "Configuration of urweb 20110917:";;
+ short | recursive ) echo "Configuration of urweb 20111127:";;
esac
cat <<\_ACEOF
@@ -1478,7 +1478,7 @@ fi
test -n "$ac_init_help" && exit $ac_status
if $ac_init_version; then
cat <<\_ACEOF
-urweb configure 20110917
+urweb configure 20111127
generated by GNU Autoconf 2.68
Copyright (C) 2010 Free Software Foundation, Inc.
@@ -1843,7 +1843,7 @@ cat >config.log <<_ACEOF
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.
-It was created by urweb $as_me 20110917, which was
+It was created by urweb $as_me 20111127, which was
generated by GNU Autoconf 2.68. Invocation command line was
$ $0 $@
@@ -2191,7 +2191,7 @@ ac_link='$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $
ac_compiler_gnu=$ac_cv_c_compiler_gnu
-WORKING_VERSION=1
+WORKING_VERSION=0
ac_ext=c
ac_cpp='$CPP $CPPFLAGS'
ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'
@@ -3970,7 +3970,7 @@ fi
# Define the identity of the package.
PACKAGE='urweb'
- VERSION='20110917'
+ VERSION='20111127'
# Some tools Automake needs.
@@ -13179,7 +13179,7 @@ cat >>$CONFIG_STATUS <<\_ACEOF || ac_write_fail=1
# report actual input values of CONFIG_FILES etc. instead of their
# values after options handling.
ac_log="
-This file was extended by urweb $as_me 20110917, which was
+This file was extended by urweb $as_me 20111127, which was
generated by GNU Autoconf 2.68. Invocation command line was
CONFIG_FILES = $CONFIG_FILES
@@ -13245,7 +13245,7 @@ _ACEOF
cat >>$CONFIG_STATUS <<_ACEOF || ac_write_fail=1
ac_cs_config="`$as_echo "$ac_configure_args" | sed 's/^ //; s/[\\""\`\$]/\\\\&/g'`"
ac_cs_version="\\
-urweb config.status 20110917
+urweb config.status 20111127
configured by $0, generated by GNU Autoconf 2.68,
with options \\"\$ac_cs_config\\"
diff --git a/configure.ac b/configure.ac
index 5176b8da..e76b9d25 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
-AC_INIT([urweb], [20110917])
-WORKING_VERSION=1
+AC_INIT([urweb], [20111127])
+WORKING_VERSION=0
AC_USE_SYSTEM_EXTENSIONS
AM_INIT_AUTOMAKE([-Wall -Werror foreign no-define])
AC_PROG_CC()