summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Adam Chlipala <adam@chlipala.net>2015-12-20 15:00:10 -0500
committerGravatar Adam Chlipala <adam@chlipala.net>2015-12-20 15:00:10 -0500
commit681382fbe032e10137d78f2308d239483c3e5731 (patch)
tree4c023edfacd392e51d14aa4fe95d079106e965b8
parentb850f7d1690a3e05cd4ccb73f012500151fb924a (diff)
Imported to Git from Mercurial
-rw-r--r--.gitignore (renamed from .hgignore)14
-rw-r--r--Makefile.am6
-rw-r--r--README.md19
-rw-r--r--configure.ac2
4 files changed, 26 insertions, 15 deletions
diff --git a/.hgignore b/.gitignore
index 20e290b8..b30fa842 100644
--- a/.hgignore
+++ b/.gitignore
@@ -1,5 +1,3 @@
-syntax: glob
-
*~
.cm
src/.cm
@@ -72,9 +70,9 @@ tests/*.db
syntax: regexp
-^Makefile$
-^src/c/Makefile$
-^libtool$
-^include/urweb/config.h$
-^include/urweb/config.h.in$
-^include/urweb/stamp-h1$
+Makefile
+src/c/Makefile
+libtool
+include/urweb/config.h
+include/urweb/config.h.in
+include/urweb/stamp-h1
diff --git a/Makefile.am b/Makefile.am
index ab11999e..9ab31acd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -105,12 +105,6 @@ uninstall-local-main:
uninstall-local: uninstall-local-main uninstall-emacs
-package:
- hg archive -t tgz -X tests "/tmp/urweb-$(VERSION).tgz"
-
-reauto:
- ./autogen.sh
-
EXTRA_DIST = demo doc lib/js lib/ur xml \
src/coq src/*.sig src/*.sml src/*.mlb src/config.sml.in src/elisp src/*.cm src/sources src/*.grm src/*.lex \
CHANGELOG LICENSE urweb.ebuild include/urweb/*.h bin
diff --git a/README.md b/README.md
new file mode 100644
index 00000000..af4201bc
--- /dev/null
+++ b/README.md
@@ -0,0 +1,19 @@
+# The Ur/Web Programming Language
+
+Implementation of a domain-specific functional programming language for web applications. Please see [the Ur/Web project web site](http://www.impredicative.com/ur/) for much more information! Here's a summary:
+
+Ur is a programming language in the tradition of ML and Haskell, but featuring a significantly richer type system. Ur is functional, pure, statically typed, and strict. Ur supports a powerful kind of metaprogramming based on row types.
+
+Ur/Web is Ur plus a special standard library and associated rules for parsing and optimization. Ur/Web supports construction of dynamic web applications backed by SQL databases. The signature of the standard library is such that well-typed Ur/Web programs "don't go wrong" in a very broad sense. Not only do they not crash during particular page generations, but they also may not:
+
+* Suffer from any kinds of code-injection attacks
+* Return invalid HTML
+* Contain dead intra-application links
+* Have mismatches between HTML forms and the fields expected by their handlers
+* Include client-side code that makes incorrect assumptions about the "AJAX"-style services that the remote web server provides
+* Attempt invalid SQL queries
+* Use improper marshaling or unmarshaling in communication with SQL databases or between browsers and web servers
+
+This type safety is just the foundation of the Ur/Web methodology. It is also possible to use metaprogramming to build significant application pieces by analysis of type structure. For instance, the demo includes an ML-style functor for building an admin interface for an arbitrary SQL table. The type system guarantees that the admin interface sub-application that comes out will always be free of the above-listed bugs, no matter which well-typed table description is given as input.
+
+The Ur/Web compiler also produces very efficient object code that does not use garbage collection. These compiled programs will often be even more efficient than what most programmers would bother to write in C. For example, the standalone web server generated for the demo uses less RAM than the bash shell. The compiler also generates JavaScript versions of client-side code, with no need to write those parts of applications in a different language.
diff --git a/configure.ac b/configure.ac
index e0249a75..6d4b7233 100644
--- a/configure.ac
+++ b/configure.ac
@@ -91,7 +91,7 @@ if test [-z $SQHEADER]; then
fi
if test [$WORKING_VERSION = "1"]; then
- VERSION="$VERSION + `hg identify || (cat .hg_archival.txt | grep 'node\:') || echo ?`"
+ VERSION="$VERSION + `git log -1 --format="%H" || (cat .hg_archival.txt | grep 'node\:') || echo ?`"
fi
# Clang does not like being passed -pthread, since it's implicit on OS X.