summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Adam Chlipala <adam@chlipala.net>2014-02-09 19:29:50 -0500
committerGravatar Adam Chlipala <adam@chlipala.net>2014-02-09 19:29:50 -0500
commit5537bc4338b4a576b225810c5cca34d3ca7de87f (patch)
tree6bbd2238f511fbefc531ca0a2e7926425ca9f26d
parenta9e2b0c2efbddf0ec9e7199c486b7f0ed736d6e8 (diff)
parent9d54ae0acdcafa014d7217c712f2ee3530ed7635 (diff)
Merge
-rw-r--r--src/c/Makefile.am2
-rw-r--r--src/elaborate.sml5
2 files changed, 4 insertions, 3 deletions
diff --git a/src/c/Makefile.am b/src/c/Makefile.am
index 8ed374f6..d117d018 100644
--- a/src/c/Makefile.am
+++ b/src/c/Makefile.am
@@ -7,7 +7,7 @@ liburweb_fastcgi_la_SOURCES = fastcgi.c fastcgi.h
liburweb_static_la_SOURCES = static.c
AM_CPPFLAGS = -I$(srcdir)/../../include/urweb $(OPENSSL_INCLUDES)
-AM_CFLAGS = -Wimplicit -Wall -Werror -Wno-format-security -Wno-deprecated-declarations $(PTHREAD_CFLAGS)
+AM_CFLAGS = -Wimplicit -Wall -Werror -Wno-format-security -Wno-deprecated-declarations -U_FORTIFY_SOURCE $(PTHREAD_CFLAGS)
liburweb_la_LDFLAGS = $(AM_LDFLAGS) $(OPENSSL_LDFLAGS)
liburweb_la_LIBADD = $(PTHREAD_LIBS) -lm $(OPENSSL_LIBS)
liburweb_http_la_LIBADD = liburweb.la
diff --git a/src/elaborate.sml b/src/elaborate.sml
index dfa8d0e2..0c8db756 100644
--- a/src/elaborate.sml
+++ b/src/elaborate.sml
@@ -873,8 +873,9 @@
| _ => false}
val (others1, others2) = eatMatching (fn (c1, c2) =>
- not (hasUnifs c1 andalso hasUnifs c2)
- andalso consEq env loc (c1, c2)) (#others s1, #others s2)
+ c1 = c2
+ orelse (not (hasUnifs c1 andalso hasUnifs c2)
+ andalso consEq env loc (c1, c2))) (#others s1, #others s2)
(*val () = eprefaces "Summaries3" [("#1", p_summary env {fields = fs1, unifs = unifs1, others = others1}),
("#2", p_summary env {fields = fs2, unifs = unifs2, others = others2})]*)