summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Adam Chlipala <adam@chlipala.net>2012-12-12 16:42:15 -0500
committerGravatar Adam Chlipala <adam@chlipala.net>2012-12-12 16:42:15 -0500
commit37860710986112437c76503f8222c092783905ef (patch)
treee4eba1ea9c294903b3ddd117830bda2267dfb8bb
parentd846d2781bf11b34fc7edc5f4c0030d6419f3d2e (diff)
Autogenerate some files
-rw-r--r--Makefile.in5
-rwxr-xr-xconfigure31
-rw-r--r--src/c/Makefile.in1
3 files changed, 21 insertions, 16 deletions
diff --git a/Makefile.in b/Makefile.in
index 6a46bb78..0514f3c8 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -151,6 +151,7 @@ MAKEINFO = @MAKEINFO@
MKDIR_P = @MKDIR_P@
MLLEX = @MLLEX@
MLTON = mlton
+MLTONARGS = @MLTONARGS@
MLYACC = @MLYACC@
MSHEADER = @MSHEADER@
NM = @NM@
@@ -563,7 +564,7 @@ distcheck: dist
*.zip*) \
unzip $(distdir).zip ;;\
esac
- chmod -R a-w $(distdir); chmod a+w $(distdir)
+ chmod -R a-w $(distdir); chmod u+w $(distdir)
mkdir $(distdir)/_build
mkdir $(distdir)/_inst
chmod a-w $(distdir)
@@ -785,7 +786,7 @@ bin/urweb: xml/entities.sml \
src/compiler.mlb src/urweb.mlb src/*.sig src/*.sml \
src/urweb.mlton.lex.sml \
src/urweb.mlton.grm.sig src/urweb.mlton.grm.sml
- $(MLTON) -output $@ src/compiler.mlb
+ $(MLTON) $(MLTONARGS) -output $@ src/compiler.mlb
xml/entities.sml: xml/parse xml/xhtml-lat1.ent xml/xhtml-special.ent xml/xhtml-symbol.ent
xml/parse >xml/entities.sml
diff --git a/configure b/configure
index 83a16937..8d956e7c 100755
--- a/configure
+++ b/configure
@@ -746,6 +746,7 @@ LIBOBJS
SQHEADER
MSHEADER
PGHEADER
+MLTONARGS
CCARGS
SITELISP
INCLUDE
@@ -5349,13 +5350,13 @@ if test "${lt_cv_nm_interface+set}" = set; then :
else
lt_cv_nm_interface="BSD nm"
echo "int some_variable = 0;" > conftest.$ac_ext
- (eval echo "\"\$as_me:5352: $ac_compile\"" >&5)
+ (eval echo "\"\$as_me:5353: $ac_compile\"" >&5)
(eval "$ac_compile" 2>conftest.err)
cat conftest.err >&5
- (eval echo "\"\$as_me:5355: $NM \\\"conftest.$ac_objext\\\"\"" >&5)
+ (eval echo "\"\$as_me:5356: $NM \\\"conftest.$ac_objext\\\"\"" >&5)
(eval "$NM \"conftest.$ac_objext\"" 2>conftest.err > conftest.out)
cat conftest.err >&5
- (eval echo "\"\$as_me:5358: output\"" >&5)
+ (eval echo "\"\$as_me:5359: output\"" >&5)
cat conftest.out >&5
if $GREP 'External.*some_variable' conftest.out > /dev/null; then
lt_cv_nm_interface="MS dumpbin"
@@ -6560,7 +6561,7 @@ ia64-*-hpux*)
;;
*-*-irix6*)
# Find out which ABI we are using.
- echo '#line 6563 "configure"' > conftest.$ac_ext
+ echo '#line 6564 "configure"' > conftest.$ac_ext
if { { eval echo "\"\$as_me\":${as_lineno-$LINENO}: \"$ac_compile\""; } >&5
(eval $ac_compile) 2>&5
ac_status=$?
@@ -7822,11 +7823,11 @@ else
-e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:7825: $lt_compile\"" >&5)
+ (eval echo "\"\$as_me:7826: $lt_compile\"" >&5)
(eval "$lt_compile" 2>conftest.err)
ac_status=$?
cat conftest.err >&5
- echo "$as_me:7829: \$? = $ac_status" >&5
+ echo "$as_me:7830: \$? = $ac_status" >&5
if (exit $ac_status) && test -s "$ac_outfile"; then
# The compiler can only warn and ignore the option if not recognized
# So say no if there are warnings other than the usual output.
@@ -8161,11 +8162,11 @@ else
-e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:8164: $lt_compile\"" >&5)
+ (eval echo "\"\$as_me:8165: $lt_compile\"" >&5)
(eval "$lt_compile" 2>conftest.err)
ac_status=$?
cat conftest.err >&5
- echo "$as_me:8168: \$? = $ac_status" >&5
+ echo "$as_me:8169: \$? = $ac_status" >&5
if (exit $ac_status) && test -s "$ac_outfile"; then
# The compiler can only warn and ignore the option if not recognized
# So say no if there are warnings other than the usual output.
@@ -8266,11 +8267,11 @@ else
-e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:8269: $lt_compile\"" >&5)
+ (eval echo "\"\$as_me:8270: $lt_compile\"" >&5)
(eval "$lt_compile" 2>out/conftest.err)
ac_status=$?
cat out/conftest.err >&5
- echo "$as_me:8273: \$? = $ac_status" >&5
+ echo "$as_me:8274: \$? = $ac_status" >&5
if (exit $ac_status) && test -s out/conftest2.$ac_objext
then
# The compiler can only warn and ignore the option if not recognized
@@ -8321,11 +8322,11 @@ else
-e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:8324: $lt_compile\"" >&5)
+ (eval echo "\"\$as_me:8325: $lt_compile\"" >&5)
(eval "$lt_compile" 2>out/conftest.err)
ac_status=$?
cat out/conftest.err >&5
- echo "$as_me:8328: \$? = $ac_status" >&5
+ echo "$as_me:8329: \$? = $ac_status" >&5
if (exit $ac_status) && test -s out/conftest2.$ac_objext
then
# The compiler can only warn and ignore the option if not recognized
@@ -10705,7 +10706,7 @@ else
lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
lt_status=$lt_dlunknown
cat > conftest.$ac_ext <<_LT_EOF
-#line 10708 "configure"
+#line 10709 "configure"
#include "confdefs.h"
#if HAVE_DLFCN_H
@@ -10801,7 +10802,7 @@ else
lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
lt_status=$lt_dlunknown
cat > conftest.$ac_ext <<_LT_EOF
-#line 10804 "configure"
+#line 10805 "configure"
#include "confdefs.h"
#if HAVE_DLFCN_H
@@ -11837,6 +11838,7 @@ fi
+
ac_config_files="$ac_config_files Makefile src/c/Makefile src/config.sml"
@@ -14193,6 +14195,7 @@ Ur/Web configuration:
site-lisp directory: SITELISP $SITELISP
C compiler: CC $CC
Extra CC args: CCARGS $CCARGS
+ Extra MLTON args: MLTONARGS $MLTONARGS
Postgres C header: PGHEADER $PGHEADER
MySQL C header: MSHEADER $MSHEADER
SQLite C header: SQHEADER $SQHEADER
diff --git a/src/c/Makefile.in b/src/c/Makefile.in
index b9ff312e..a0bc1c32 100644
--- a/src/c/Makefile.in
+++ b/src/c/Makefile.in
@@ -154,6 +154,7 @@ MAKEINFO = @MAKEINFO@
MKDIR_P = @MKDIR_P@
MLLEX = @MLLEX@
MLTON = @MLTON@
+MLTONARGS = @MLTONARGS@
MLYACC = @MLYACC@
MSHEADER = @MSHEADER@
NM = @NM@