summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Adam Chlipala <adamc@hcoop.net>2009-12-31 16:12:13 -0500
committerGravatar Adam Chlipala <adamc@hcoop.net>2009-12-31 16:12:13 -0500
commit00b1094540b7ae07941b97e3714967eb4519cb1b (patch)
tree448d9b0895702b655a8becbd338e628e4c5af523
parent7c4572e3a03a06822a27345b1b44cdeb0087a950 (diff)
Change location of dynamic libraries
-rw-r--r--Makefile.in12
-rw-r--r--src/compiler.sml2
2 files changed, 7 insertions, 7 deletions
diff --git a/Makefile.in b/Makefile.in
index 32e123b4..a7c785e5 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -84,18 +84,18 @@ install:
cp lib/ur/*.ur $(LIB_UR)/
mkdir -p $(LIB_C)
cp lib/c/*.o $(LIB_C)/
- cp lib/c/*.so.$(LD_MAJOR).$(LD_MINOR) $(LIB_C)/
+ cp lib/c/*.so.$(LD_MAJOR).$(LD_MINOR) $(LIB)/..
mkdir -p $(LIB_JS)
cp lib/js/*.js $(LIB_JS)/
mkdir -p $(INCLUDE)
cp include/*.h $(INCLUDE)/
mkdir -p $(SITELISP)
cp src/elisp/*.el $(SITELISP)/
- ldconfig $(LIB_C)
- ln -sf $(LIB_C)/liburweb.so.$(LD_MAJOR) $(LIB_C)/liburweb.so
- ln -sf $(LIB_C)/liburweb_http.so.$(LD_MAJOR) $(LIB_C)/liburweb_http.so
- ln -sf $(LIB_C)/liburweb_cgi.so.$(LD_MAJOR) $(LIB_C)/liburweb_cgi.so
- ln -sf $(LIB_C)/liburweb_fastcgi.so.$(LD_MAJOR) $(LIB_C)/liburweb_fastcgi.so
+ ln -sf liburweb.so.$(LD_MAJOR) $(LIB)/../liburweb.so
+ ln -sf liburweb_http.so.$(LD_MAJOR) $(LIB)/../liburweb_http.so
+ ln -sf liburweb_cgi.so.$(LD_MAJOR) $(LIB)/../liburweb_cgi.so
+ ln -sf /liburweb_fastcgi.so.$(LD_MAJOR) $(LIB)/../liburweb_fastcgi.so
+ ldconfig
package:
hg archive -t tgz -X tests /tmp/urweb.tgz
diff --git a/src/compiler.sml b/src/compiler.sml
index 026df6fd..625d71ff 100644
--- a/src/compiler.sml
+++ b/src/compiler.sml
@@ -1031,7 +1031,7 @@ fun compileC {cname, oname, ename, libs, profile, debug, link = link'} =
clibFile "request.o" ^ " " ^ clibFile "queue.o" ^ " " ^ clibFile "urweb.o"
^ " " ^ clibFile "memmem.o" ^ " " ^ clibFile "mhash.o" ^ " " ^ #linkStatic proto
else
- "-L" ^ Config.libC ^ " -lurweb " ^ #linkDynamic proto
+ "-L" ^ Config.lib ^ "/.. -lurweb " ^ #linkDynamic proto
val compile = "gcc " ^ Config.gccArgs ^ " -Wimplicit -Werror -O3 -fno-inline -I " ^ Config.includ
^ " " ^ #compile proto