summaryrefslogtreecommitdiff
path: root/data
diff options
context:
space:
mode:
Diffstat (limited to 'data')
-rw-r--r--data/Makefile.am14
-rw-r--r--data/io.github.TransmissionRemoteGtk.appdata.xml.in51
-rw-r--r--data/io.github.TransmissionRemoteGtk.desktop.in (renamed from data/transmission-remote-gtk.desktop.in)4
-rw-r--r--data/transmission-remote-gtk.appdata.xml.in32
4 files changed, 62 insertions, 39 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index 852a02d..ad5c5cd 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -1,15 +1,19 @@
SUBDIRS = icons
-desktop_in_files = transmission-remote-gtk.desktop.in
+%.desktop: %.desktop.in
+ $(AM_V_GEN)$(MSGFMT) --desktop --template $< -d $(top_srcdir)/po -o $@
+
+desktop_in_files = io.github.TransmissionRemoteGtk.desktop.in
desktop_FILES = $(desktop_in_files:.desktop.in=.desktop)
-@INTLTOOL_DESKTOP_RULE@
@DESKTOP_FILE_RULES@
-appstream_in_files = transmission-remote-gtk.appdata.xml.in
+%.appdata.xml: %.appdata.xml.in
+ $(AM_V_GEN)$(MSGFMT) --xml --template $< -d $(top_srcdir)/po -o $@
+
+appstream_in_files = io.github.TransmissionRemoteGtk.appdata.xml.in
appstream_XML = $(appstream_in_files:.xml.in=.xml)
-@INTLTOOL_XML_RULE@
@APPSTREAM_XML_RULES@
EXTRA_DIST = $(desktop_in_files) $(appstream_in_files)
-DISTCLEANFILES = $(desktop_FILES) $(appstream_XML)
+CLEANFILES = $(desktop_FILES) $(appstream_XML)
diff --git a/data/io.github.TransmissionRemoteGtk.appdata.xml.in b/data/io.github.TransmissionRemoteGtk.appdata.xml.in
new file mode 100644
index 0000000..2d70e76
--- /dev/null
+++ b/data/io.github.TransmissionRemoteGtk.appdata.xml.in
@@ -0,0 +1,51 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!-- Copyright 2014 Alan F -->
+<component type="desktop">
+ <id>io.github.TransmissionRemoteGtk</id>
+ <metadata_license>CC0-1.0</metadata_license>
+ <project_license>GPL-2.0+</project_license>
+ <translation type="gettext">transmission-remote-gtk</translation>
+ <name>Transmission Remote</name>
+ <developer_name>Transmission Remote Gtk Team</developer_name>
+ <summary>Remotely manage the Transmission BitTorrent client</summary>
+ <url type="homepage">https://github.com/transmission-remote-gtk/transmission-remote-gtk</url>
+ <url type="bugtracker">https://github.com/transmission-remote-gtk/transmission-remote-gtk/issues</url>
+ <description>
+ <p>
+ Transmission Remote Gtk allows you to remotely manage the Transmission BitTorrent client using its RPC interface.
+ </p>
+ <p>Features:</p>
+ <ul>
+ <li>Remotely add (file/url), start, stop, remove, remove and delete, verify, reannounce torrents</li>
+ <li>Works as a .torrent handler (eg. from a web browser)</li>
+ <li>Set torrent properties such as speed, seed, peer limits, file priorities, add/edit/remove trackers</li>
+ <li>Change remote settings like global limits, download directory, and connectivity preferences</li>
+ </ul>
+ </description>
+ <screenshots>
+ <screenshot height="576" width="1024" type="default">
+ <image>http://eth0.org.uk/~alan/transmission-remote-gtk-1.1.1.png</image>
+ </screenshot>
+ </screenshots>
+ <releases>
+ <release version="1.4.0" date="2018-11-02">
+ <description>
+ <p>This is a minor release with some improvements:</p>
+ <ul>
+ <li>Rename app-id to io.github.TransmissionRemoteGtk</li>
+ <li>Add configuration of alternate speed days to preferences</li>
+ <li>Add menu option to copy magnet links</li>
+ <li>Add Ctrl+q keybinding to quit</li>
+ <li>Fix building with GeoIP support</li>
+ <li>Fix setting speeds in preferences</li>
+ <li>Improve search behavior in file view</li>
+ </ul>
+ </description>
+ </release>
+ </releases>
+ <launchable type="desktop-id">io.github.TransmissionRemoteGtk.desktop</launchable>
+ <provides>
+ <id>uk.org.eth0.transmission-remote-gtk.desktop</id>
+ </provides>
+ <update_contact>tingping_at_fedoraproject.org</update_contact>
+</component>
diff --git a/data/transmission-remote-gtk.desktop.in b/data/io.github.TransmissionRemoteGtk.desktop.in
index 776a6f7..d52cd80 100644
--- a/data/transmission-remote-gtk.desktop.in
+++ b/data/io.github.TransmissionRemoteGtk.desktop.in
@@ -1,6 +1,6 @@
[Desktop Entry]
-_Name=Transmission Remote
-_Comment=Remotely manage the Transmission BitTorrent client
+Name=Transmission Remote
+Comment=Remotely manage the Transmission BitTorrent client
Exec=transmission-remote-gtk %U
Icon=transmission-remote-gtk
Terminal=false
diff --git a/data/transmission-remote-gtk.appdata.xml.in b/data/transmission-remote-gtk.appdata.xml.in
deleted file mode 100644
index 1d701f4..0000000
--- a/data/transmission-remote-gtk.appdata.xml.in
+++ /dev/null
@@ -1,32 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!-- Copyright 2014 Alan F -->
-<component type="desktop">
- <id>transmission-remote-gtk.desktop</id>
- <metadata_license>CC0-1.0</metadata_license>
- <project_license>GPL-2.0+</project_license>
- <project_group>GNOME</project_group>
- <translation type="gettext">transmission-remote-gtk</translation>
- <name>Transmission Remote</name>
- <_developer_name>Transmission Remote Gtk Team</_developer_name>
- <summary>Remotely manage the Transmission BitTorrent client</summary>
- <url type="homepage">https://github.com/transmission-remote-gtk/transmission-remote-gtk</url>
- <url type="bugtracker">https://github.com/transmission-remote-gtk/transmission-remote-gtk/issues</url>
- <description>
- <_p>
- Transmission Remote Gtk allows you to remotely manage the Transmission BitTorrent client using its RPC interface.
- </_p>
- <_p>Features:</_p>
- <ul>
- <_li>Remotely add (file/url), start, stop, remove, remove and delete, verify, reannounce torrents</_li>
- <_li>Works as a .torrent handler (eg. from a web browser)</_li>
- <_li>Set torrent properties such as speed, seed, peer limits, file priorities, add/edit/remove trackers</_li>
- <_li>Change remote settings like global limits, download directory, and connectivity preferences</_li>
- </ul>
- </description>
- <screenshots>
- <screenshot height="576" width="1024" type="default">
- <image>http://eth0.org.uk/~alan/transmission-remote-gtk-1.1.1.png</image>
- </screenshot>
- </screenshots>
- <update_contact>tingping_at_fedoraproject.org</update_contact>
-</component>