summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ab52685..af1c9fe 100644
--- a/configure.ac
+++ b/configure.ac
@@ -170,6 +170,12 @@ AS_IF([test "$enable_debug" = "no"], [
AX_APPEND_COMPILE_FLAGS([-O2])
])
+AX_APPEND_LINK_FLAGS([ \
+ -pie \
+ -Wl,-z,relro \
+ -Wl,-z,now \
+])
+
AC_CONFIG_FILES([
Makefile
po/Makefile.in