summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--src/Makefile.am2
-rw-r--r--src/trg-torrent-model.c4
2 files changed, 3 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 338a58a..26cd0df 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -44,7 +44,7 @@ desktop_DATA = transmission-remote-gtk.desktop
endif
bin_PROGRAMS = transmission-remote-gtk
-INCLUDES = --pedantic -Wall -I.. -Wno-overflow -DTRGLICENSE=\""$(trglicense)"\" $(libcurl_CFLAGS) $(jsonglib_CFLAGS) $(gthread_CFLAGS) $(gtk_CFLAGS) $(gio_CFLAGS) $(unique_CFLAGS) $(notify_CFLAGS) $(libproxy_CFLAGS) $(libappindicator_CFLAGS)
+INCLUDES = -std=c99 --pedantic -Wall -I.. -Wno-overflow -DTRGLICENSE=\""$(trglicense)"\" $(libcurl_CFLAGS) $(jsonglib_CFLAGS) $(gthread_CFLAGS) $(gtk_CFLAGS) $(gio_CFLAGS) $(unique_CFLAGS) $(notify_CFLAGS) $(libproxy_CFLAGS) $(libappindicator_CFLAGS)
transmission_remote_gtk_SOURCES = \
trg-cell-renderer-speed.c \
diff --git a/src/trg-torrent-model.c b/src/trg-torrent-model.c
index 8e8bcc5..cf490c3 100644
--- a/src/trg-torrent-model.c
+++ b/src/trg-torrent-model.c
@@ -454,7 +454,7 @@ update_torrent_iter(TrgTorrentModel * model,
if (newFlags & TORRENT_FLAG_ACTIVE) {
if (lpd >= 0) {
peerSources =
- g_strdup_printf("%ld / %ld / %ld / %ld / %ld / %ld / %ld",
+ g_strdup_printf("%"G_GINT64_FORMAT" / %"G_GINT64_FORMAT" / %"G_GINT64_FORMAT" / %"G_GINT64_FORMAT" / %"G_GINT64_FORMAT" / %"G_GINT64_FORMAT" / %"G_GINT64_FORMAT,
peerfrom_get_trackers(pf),
peerfrom_get_incoming(pf),
peerfrom_get_ltep(pf),
@@ -462,7 +462,7 @@ update_torrent_iter(TrgTorrentModel * model,
lpd, peerfrom_get_resume(pf));
} else {
peerSources =
- g_strdup_printf("%ld / %ld / %ld / %ld / %ld / N/A / %ld",
+ g_strdup_printf("%"G_GINT64_FORMAT" / %"G_GINT64_FORMAT" / %"G_GINT64_FORMAT" / %"G_GINT64_FORMAT" / %"G_GINT64_FORMAT" / N/A / %"G_GINT64_FORMAT,
peerfrom_get_trackers(pf),
peerfrom_get_incoming(pf),
peerfrom_get_ltep(pf),