summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--configure.ac2
-rw-r--r--redhat/transmission-remote-gtk.spec29
-rw-r--r--src/Makefile.am2
-rw-r--r--src/trg-main-window.c59
-rw-r--r--src/trg-torrent-add-dialog.c12
-rw-r--r--src/trg-torrent-add-url-dialog.c2
-rw-r--r--src/trg-torrent-move-dialog.c2
7 files changed, 57 insertions, 51 deletions
diff --git a/configure.ac b/configure.ac
index e4ac719..462b8fe 100644
--- a/configure.ac
+++ b/configure.ac
@@ -27,7 +27,7 @@ case "$OSNAME" in
esac
trglocaledir='${prefix}/${DATADIRNAME}/locale'
-trglicense='${docdir}/LICENSE.GPLv2'
+trglicense='${docdir}/COPYING'
AC_SUBST(trglocaledir)
AC_SUBST(trglicense)
GETTEXT_PACKAGE=AC_PACKAGE_NAME
diff --git a/redhat/transmission-remote-gtk.spec b/redhat/transmission-remote-gtk.spec
index 6bc9c9e..d24f2de 100644
--- a/redhat/transmission-remote-gtk.spec
+++ b/redhat/transmission-remote-gtk.spec
@@ -83,16 +83,29 @@ fi
%{_sysconfdir}/gconf/schemas/%{name}.schemas
%{_bindir}/%{name}
%{_datadir}/applications/%{name}.desktop
-%{_datadir}/icons/hicolor/scalable/apps/transmission-remote-gtk.svg
-%{_datadir}/icons/hicolor/16x16/apps/transmission-remote-gtk.png
-%{_datadir}/icons/hicolor/22x22/apps/transmission-remote-gtk.png
-%{_datadir}/icons/hicolor/24x24/apps/transmission-remote-gtk.png
-%{_datadir}/icons/hicolor/32x32/apps/transmission-remote-gtk.png
-%{_datadir}/icons/hicolor/48x48/apps/transmission-remote-gtk.png
-%{_datadir}/locale/de/LC_MESSAGES/transmission-remote-gtk.mo
-%{_datadir}/locale/ko/LC_MESSAGES/transmission-remote-gtk.mo
+%{_datadir}/icons/hicolor/scalable/apps/%{name}.svg
+%{_datadir}/icons/hicolor/16x16/apps/%{name}.png
+%{_datadir}/icons/hicolor/22x22/apps/%{name}.png
+%{_datadir}/icons/hicolor/24x24/apps/%{name}.png
+%{_datadir}/icons/hicolor/32x32/apps/%{name}.png
+%{_datadir}/icons/hicolor/48x48/apps/%{name}.png
+%{_datadir}/locale/de/LC_MESSAGES/%{name}.mo
+%{_datadir}/locale/ko/LC_MESSAGES/%{name}.mo
+%{_datadir}/locale/pl/LC_MESSAGES/%{name}.mo
+%{_datadir}/locale/ru/LC_MESSAGES/%{name}.mo
%changelog
+* Tue Apr 12 2011 Alan Fitton <alan@eth0.org.uk> - 0.4
+- Torrent add dialog.
+- Support for active only updates.
+- Other update performance improvements.
+- Pause/Resume all.
+- Polish and Russian translation.
+- Torrent added date/time column.
+- Fix gconf ints defaulting to one in prefs dialog.
+- Fix crash disconnecting with graph disabled.
+- Fix crash disabling tracker/dir filters while disconnected.
+
* Sat Mar 11 2011 Alan Fitton <alan@eth0.org.uk> - 0.3
- Case insensitive text filtering.
- Speed graph.
diff --git a/src/Makefile.am b/src/Makefile.am
index ecb6b3b..13a02e7 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -80,7 +80,7 @@ transmission_remote_gtk_LDFLAGS = -lm -lcurl $(jsonglib_LIBS) $(gtk_LIBS) $(gthr
install-data-local: install-icons update-icon-cache
GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) gconftool-2 --makefile-install-rule $(srcdir)/$(schema_DATA)
- $(INSTALL_DATA) -D ../COPYING $(docdir)/LICENSE.GPLv2
+ $(INSTALL_DATA) -D ../COPYING $(docdir)/COPYING
$(INSTALL_DATA) ../AUTHORS $(docdir)/AUTHORS
$(INSTALL_DATA) ../README $(docdir)/README
diff --git a/src/trg-main-window.c b/src/trg-main-window.c
index 52b5bc5..b444237 100644
--- a/src/trg-main-window.c
+++ b/src/trg-main-window.c
@@ -272,13 +272,11 @@ static void torrent_event_notification(TrgTorrentModel * model,
gint tmout, gchar * prefKey,
GtkTreeIter * iter, gpointer data)
{
- TrgMainWindowPrivate *priv;
+ TrgMainWindowPrivate *priv = TRG_MAIN_WINDOW_GET_PRIVATE(data);
gchar *name;
NotifyNotification *notify;
- priv = TRG_MAIN_WINDOW_GET_PRIVATE(data);
-
- if (priv->statusIcon == NULL
+ if (!priv->statusIcon
|| !gtk_status_icon_is_embedded(priv->statusIcon))
return;
@@ -847,7 +845,7 @@ static void on_session_get(JsonObject * response, int status,
newSession = get_arguments(response);
- if (client->session == NULL) {
+ if (!client->session) {
float version;
if (session_get_version(newSession, &version))
{
@@ -1099,9 +1097,7 @@ static gboolean
trg_dialog_error_handler(TrgMainWindow * win, JsonObject * response,
int status)
{
- TrgMainWindowPrivate *priv;
-
- priv = TRG_MAIN_WINDOW_GET_PRIVATE(win);
+ TrgMainWindowPrivate *priv = TRG_MAIN_WINDOW_GET_PRIVATE(win);
if (status != CURLE_OK) {
GtkWidget *dialog;
@@ -1126,16 +1122,9 @@ trg_dialog_error_handler(TrgMainWindow * win, JsonObject * response,
static gboolean
torrent_selection_changed(GtkWidget * w G_GNUC_UNUSED, gpointer data)
{
- TrgMainWindow *win;
- TrgMainWindowPrivate *priv;
- gboolean isSelected;
- trg_client *client;
-
- priv = TRG_MAIN_WINDOW_GET_PRIVATE(data);
- win = TRG_MAIN_WINDOW(data);
- client = priv->client;
-
- isSelected = update_selected_torrent_notebook(win, TORRENT_GET_MODE_FIRST);
+ TrgMainWindowPrivate *priv = TRG_MAIN_WINDOW_GET_PRIVATE(data);
+ TrgMainWindow *win = TRG_MAIN_WINDOW(data);
+ gboolean isSelected = update_selected_torrent_notebook(win, TORRENT_GET_MODE_FIRST);
trg_toolbar_torrent_actions_sensitive(priv->toolBar, isSelected);
trg_menu_bar_torrent_actions_sensitive(priv->menuBar, isSelected);
@@ -1153,7 +1142,7 @@ on_generic_interactive_action(JsonObject * response, int status,
{
TrgMainWindowPrivate *priv = TRG_MAIN_WINDOW_GET_PRIVATE(data);
- if (priv->client->session != NULL) {
+ if (priv->client->session) {
gdk_threads_enter();
trg_dialog_error_handler(TRG_MAIN_WINDOW(data), response, status);
gdk_threads_leave();
@@ -1389,10 +1378,10 @@ static void set_limit_cb(GtkWidget * w, gpointer data)
JsonNode *req = NULL;
JsonObject *args;
- if (limitIds == NULL) {
- req = session_set();
- } else {
+ if (limitIds) {
req = torrent_set((JsonArray *) limitIds);
+ } else {
+ req = session_set();
}
args = node_get_arguments(req);
@@ -1402,11 +1391,11 @@ static void set_limit_cb(GtkWidget * w, gpointer data)
json_object_set_boolean_member(args, enabledKey, speed >= 0);
- if (limitIds == NULL)
- dispatch_async(priv->client, req, on_session_set, data);
- else
+ if (limitIds)
dispatch_async(priv->client, req, on_generic_interactive_action,
- data);
+ data);
+ else
+ dispatch_async(priv->client, req, on_session_set, data);
}
static GtkWidget *limit_item_new(TrgMainWindow * win, GtkWidget * menu,
@@ -1443,11 +1432,11 @@ static GtkWidget *limit_menu_new(TrgMainWindow * win, gchar * title,
GtkWidget *toplevel, *menu, *item;
gint64 limit;
- if (ids == NULL)
- current = priv->client->session;
- else
+ if (ids)
get_first_selected(priv->client, priv->torrentTreeView, &iter,
- &current);
+ &current);
+ else
+ current = priv->client->session;
limit = json_object_get_boolean_member(current, enabledKey) ?
json_object_get_int_member(current, speedKey) : -1;
@@ -1673,7 +1662,7 @@ static void status_bar_text_pushed(GtkStatusbar * statusbar,
{
TrgMainWindowPrivate *priv = TRG_MAIN_WINDOW_GET_PRIVATE(user_data);
- if (priv->statusIcon != NULL)
+ if (priv->statusIcon)
gtk_status_icon_set_tooltip(priv->statusIcon, text);
}
@@ -1683,7 +1672,7 @@ static gboolean window_state_event(GtkWidget * widget,
{
TrgMainWindowPrivate *priv = TRG_MAIN_WINDOW_GET_PRIVATE(widget);
- if (priv->statusIcon != NULL
+ if (priv->statusIcon
&& event->changed_mask == GDK_WINDOW_STATE_ICONIFIED
&& (event->new_window_state == GDK_WINDOW_STATE_ICONIFIED
|| event->new_window_state ==
@@ -1709,7 +1698,7 @@ void trg_main_window_remove_status_icon(TrgMainWindow * win)
{
TrgMainWindowPrivate *priv = TRG_MAIN_WINDOW_GET_PRIVATE(win);
- if (priv->statusIcon != NULL)
+ if (priv->statusIcon)
g_object_unref(G_OBJECT(priv->statusIcon));
priv->statusIcon = NULL;
@@ -1747,7 +1736,7 @@ void trg_main_window_add_status_icon(TrgMainWindow * win)
{
TrgMainWindowPrivate *priv = TRG_MAIN_WINDOW_GET_PRIVATE(win);
- if (priv->icon == NULL)
+ if (!priv->icon)
return;
priv->statusIcon = gtk_status_icon_new_from_pixbuf(priv->icon);
@@ -1964,7 +1953,7 @@ void auto_connect_if_required(TrgMainWindow * win, trg_client * tc)
gchar *host =
gconf_client_get_string(tc->gconf, TRG_GCONF_KEY_HOSTNAME,
NULL);
- if (host != NULL) {
+ if (host) {
gint len = strlen(host);
g_free(host);
if (len > 0
diff --git a/src/trg-torrent-add-dialog.c b/src/trg-torrent-add-dialog.c
index 06b1c9b..cf2c83a 100644
--- a/src/trg-torrent-add-dialog.c
+++ b/src/trg-torrent-add-dialog.c
@@ -194,15 +194,19 @@ static GtkWidget *trg_destination_folder_new(trg_client * client)
GList *li;
GList *torrentItemRefs;
+ GtkTreeRowReference *rr;
+ GtkTreeModel *model;
+ GtkTreePath *path;
+ JsonObject *t;
+
g_slist_str_set_add(&dirs, defaultDownDir);
g_mutex_lock(client->updateMutex);
torrentItemRefs = g_hash_table_get_values(client->torrentTable);
for (li = torrentItemRefs; li; li = g_list_next(li)) {
- GtkTreeRowReference *rr = (GtkTreeRowReference*)li->data;
- GtkTreeModel *model = gtk_tree_row_reference_get_model(rr);
- GtkTreePath *path = gtk_tree_row_reference_get_path(rr);
- JsonObject *t = NULL;
+ rr = (GtkTreeRowReference*)li->data;
+ model = gtk_tree_row_reference_get_model(rr);
+ path = gtk_tree_row_reference_get_path(rr);
if (path) {
GtkTreeIter iter;
diff --git a/src/trg-torrent-add-url-dialog.c b/src/trg-torrent-add-url-dialog.c
index 9a2d72e..737c749 100644
--- a/src/trg-torrent-add-url-dialog.c
+++ b/src/trg-torrent-add-url-dialog.c
@@ -83,7 +83,7 @@ static void trg_torrent_add_url_dialog_init(TrgTorrentAddUrlDialog * self)
w = priv->urlEntry = gtk_entry_new();
g_signal_connect(w, "changed", G_CALLBACK(url_entry_changed), self);
- w = hig_workarea_add_row(t, &row, "URL:", w, NULL);
+ hig_workarea_add_row(t, &row, _("URL:"), w, NULL);
priv->startCheck =
hig_workarea_add_wide_checkbutton(t, &row, _("Start Paused"),
diff --git a/src/trg-torrent-move-dialog.c b/src/trg-torrent-move-dialog.c
index 77781c6..6b2c4a0 100644
--- a/src/trg-torrent-move-dialog.c
+++ b/src/trg-torrent-move-dialog.c
@@ -93,7 +93,7 @@ static void trg_torrent_move_dialog_init(TrgTorrentMoveDialog * self)
w = priv->location_combo = gtk_combo_box_entry_new_text();
g_signal_connect(w, "changed", G_CALLBACK(location_changed), self);
- w = hig_workarea_add_row(t, &row, _("Location:"), w, NULL);
+ hig_workarea_add_row(t, &row, _("Location:"), w, NULL);
priv->move_check =
hig_workarea_add_wide_checkbutton(t, &row, _("Move"), TRUE);