summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--AUTHORS2
-rw-r--r--redhat/transmission-remote-gtk.spec10
-rw-r--r--src/Makefile.am2
3 files changed, 12 insertions, 2 deletions
diff --git a/AUTHORS b/AUTHORS
index 22039bb..f4bd00b 100644
--- a/AUTHORS
+++ b/AUTHORS
@@ -14,4 +14,4 @@ translations kindly contributed by
* Youn sok Choi (Korean)
* Piotr (Polish)
* Y3AVD (Russian)
-
+ * ROR191 (Ukranian)
diff --git a/redhat/transmission-remote-gtk.spec b/redhat/transmission-remote-gtk.spec
index e5ae8f2..eb5a1d4 100644
--- a/redhat/transmission-remote-gtk.spec
+++ b/redhat/transmission-remote-gtk.spec
@@ -1,5 +1,5 @@
Name: transmission-remote-gtk
-Version: 0.5.1
+Version: 0.5.2
Release: 1%{?dist:%{dist}}
Summary: Remote control client for Transmission BitTorrent
@@ -41,6 +41,7 @@ make %{?_smp_mflags}
%install
rm -rf $RPM_BUILD_ROOT
+make install DESTDIR=$RPM_BUILD_ROOT
%clean
rm -rf $RPM_BUILD_ROOT
@@ -67,8 +68,15 @@ update-desktop-database %{_datadir}/applications >/dev/null 2>&1
%{_datadir}/locale/ko/LC_MESSAGES/%{name}.mo
%{_datadir}/locale/pl/LC_MESSAGES/%{name}.mo
%{_datadir}/locale/ru/LC_MESSAGES/%{name}.mo
+%{_datadir}/locale/uk/LC_MESSAGES/%{name}.mo
%changelog
+* Sat Aug 27 2011 Alan Fitton <alan@eth0.org.uk> 0.5.2
+- Profiles support.
+- New JSON based configuration backend.
+- Populate destination combo in move dialog.
+- Ukranian translation from ROR191.
+
* Fri May 6 2011 Alan Fitton <alan@eth0.org.uk> - 0.5.1
- Use libproxy pkg-config CFLAGS in build, for older versions.
- Fix updates inside the GtkNotebook.
diff --git a/src/Makefile.am b/src/Makefile.am
index 0a9d155..3339143 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -77,6 +77,8 @@ transmission_remote_gtk_SOURCES = main.c \
transmission_remote_gtk_LDFLAGS = -lm -lcurl $(jsonglib_LIBS) $(gtk_LIBS) $(gthread_LIBS) $(GEOIP_LIBS) $(gio_LIBS) $(unique_LIBS) $(notify_LIBS) $(libproxy_LIBS)
+install-data-local: install-icons update-icon-cache
+
gtk_update_icon_cache = gtk-update-icon-cache -f -t
update-icon-cache: