summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--redhat/transmission-remote-gtk.spec13
-rw-r--r--src/Makefile.am9
-rw-r--r--src/main.c2
-rw-r--r--src/transmission-remote-gtk.pod57
-rw-r--r--src/trg-persistent-tree-view.c3
-rw-r--r--src/trg-preferences-dialog.c2
6 files changed, 76 insertions, 10 deletions
diff --git a/redhat/transmission-remote-gtk.spec b/redhat/transmission-remote-gtk.spec
index a8dbe19..950796b 100644
--- a/redhat/transmission-remote-gtk.spec
+++ b/redhat/transmission-remote-gtk.spec
@@ -27,9 +27,6 @@ BuildRequires: json-glib-devel
BuildRequires: libcurl-devel
BuildRequires: libnotify-devel
-Requires(post): desktop-file-utils
-Requires(postun): desktop-file-utils
-
%description
transmission-remote-gtk is a GTK application for remote management of the
Transmission BitTorrent client via its RPC interface.
@@ -49,10 +46,16 @@ make install DESTDIR=$RPM_BUILD_ROOT
rm -rf $RPM_BUILD_ROOT
%post
-update-desktop-database %{_datadir}/applications >/dev/null 2>&1
+/bin/touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
%postun
-update-desktop-database %{_datadir}/applications >/dev/null 2>&1
+if [ $1 -eq 0 ] ; then
+ /bin/touch --no-create %{_datadir}/icons/hicolor &>/dev/null
+ /usr/bin/gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
+fi
+
+%postrans
+/usr/bin/gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%files
%defattr(-,root,root,-)
diff --git a/src/Makefile.am b/src/Makefile.am
index 5c5741d..827e304 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -13,8 +13,10 @@ public_icons = \
hicolor_apps_32x32_transmission-remote-gtk.png \
$(NULL)
-EXTRA_DIST = transmission-remote-gtk.desktop.in
-CLEANFILES = transmission-remote-gtk.desktop
+EXTRA_DIST = transmission-remote-gtk.desktop.in transmission-remote-gtk.pod
+CLEANFILES = transmission-remote-gtk.desktop transmission-remote-gtk.1
+
+man_MANS = transmission-remote-gtk.1
desktopdir = $(datadir)/applications
desktop_DATA = transmission-remote-gtk.desktop
@@ -84,6 +86,9 @@ transmission_remote_gtk_LDFLAGS += -Wl,--subsystem,windows
transmission_remote_gtk_SOURCES += win32.rc
endif
+%.1: %.pod
+ pod2man --release="" --center="Transmission Remote GTK" $< > $@
+
install-data-local: install-icons update-icon-cache
gtk_update_icon_cache = gtk-update-icon-cache -f -t
diff --git a/src/main.c b/src/main.c
index 5c58293..79ad11b 100644
--- a/src/main.c
+++ b/src/main.c
@@ -159,7 +159,7 @@ static gpointer mailslot_recv_thread(gpointer data) {
if (arrayList) {
guint arrayLength = g_list_length(arrayList);
- int i = 0;
+ guint i = 0;
GList *li;
args->uris = g_new0(gchar*, arrayLength+1);
diff --git a/src/transmission-remote-gtk.pod b/src/transmission-remote-gtk.pod
new file mode 100644
index 0000000..de7c575
--- /dev/null
+++ b/src/transmission-remote-gtk.pod
@@ -0,0 +1,57 @@
+
+=head1 NAME
+
+transmission-remote-gtk - RPC client for the Transmission bittorrent client.
+
+=head1 SYNOPSIS
+
+B<transmission-remote-gtk> [OPTIONS] [torrent file|magnet link|url]
+
+=head1 DESCRIPTION
+
+B<transmission-remote-gtk> is an application for remote management of the
+Transmission BitTorrent client using its RPC interface.
+
+=head1 OPTIONS
+
+The following options are accepted when running C<transmission-remote-gtk>:
+
+=over 1
+
+=item -m, --minimized, /m
+
+Start the application minimized
+
+=back
+
+=head1 ENVIRONMENT
+
+=over 1
+
+=item TRG_NOUNIQUE
+
+Start a new instance, even if one already exists.
+
+=back
+
+=head1 AUTHOR
+
+Written by Alan Fitton.
+
+=head1 BUGS
+
+Please see L<http://code.google.com/p/transmission-remote-gtk/issues>
+
+=head1 COPYRIGHT
+
+Copyright (C) 2011 Alan Fitton and various contributors.
+This is free software. You may redistribute copies of it under the terms of the GNU General
+Public License C<http://www.gnu.org/licenses/gpl.html>. There is NO WARRANTY, to the extent
+permitted by law.
+
+=head1 SEE ALSO
+
+C<transmission-daemon(1)>, C<transmission-gtk(1)>, the project website C<http://code.google.com/p/transmission-remote-gtk/>
+
+=cut
+
diff --git a/src/trg-persistent-tree-view.c b/src/trg-persistent-tree-view.c
index d023963..e3a84c1 100644
--- a/src/trg-persistent-tree-view.c
+++ b/src/trg-persistent-tree-view.c
@@ -245,6 +245,7 @@ static void trg_persistent_tree_view_finalize(GObject *object) {
g_free(cd);
}
g_slist_free(priv->columns);
+ g_free(priv->key);
G_OBJECT_CLASS (trg_persistent_tree_view_parent_class)->finalize(object);
}
@@ -351,7 +352,7 @@ TrgPersistentTreeView*
trg_persistent_tree_view_new(TrgPrefs *prefs, GtkListStore *model,
const gchar *key) {
GObject *obj = g_object_new(TRG_TYPE_PERSISTENT_TREE_VIEW, "prefs", prefs,
- "conf-key", key, "persistent-model", model, NULL);
+ "conf-key", g_strdup(key), "persistent-model", model, NULL);
return TRG_PERSISTENT_TREE_VIEW(obj);
}
diff --git a/src/trg-preferences-dialog.c b/src/trg-preferences-dialog.c
index 8755ce8..331f60e 100644
--- a/src/trg-preferences-dialog.c
+++ b/src/trg-preferences-dialog.c
@@ -585,7 +585,7 @@ static GtkWidget *trg_prefs_dirsPage(TrgPreferencesDialog *dlg) {
t = hig_workarea_create();
- hig_workarea_add_section_title(t, &row, _("Destinations"));
+ hig_workarea_add_section_title(t, &row, _("Remote Download Directories"));
model = gtk_list_store_new(2, G_TYPE_STRING, G_TYPE_STRING);