summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorGravatar Alan Fitton <ajf@eth0.org.uk>2011-04-29 09:32:38 +0000
committerGravatar Alan Fitton <ajf@eth0.org.uk>2011-04-29 09:32:38 +0000
commitc0bae6b1b517feefbef197d55a72bb62e056b21e (patch)
treef6172ea4ffcfa2efde2223bf48d9271ef20594bc /src
parentcc9226065093d98cb857eecbd1b14b744af32e88 (diff)
earlier versions of the libproxy header were in /usr/include/libproxy instead of /usr/include, so including the cflags from pkgconfig should fix this.
Diffstat (limited to 'src')
-rw-r--r--src/Makefile.am2
-rw-r--r--src/trg-main-window.c21
2 files changed, 8 insertions, 15 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 11086c4..ab258c3 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -23,7 +23,7 @@ schemadir = @GCONF_SCHEMA_FILE_DIR@
schema_DATA = transmission-remote-gtk.schemas
bin_PROGRAMS = transmission-remote-gtk
-INCLUDES = --pedantic -Wall -I.. -O2 -DTRGLICENSE=\""$(trglicense)"\" -DTRGLOCALEDIR=\""$(trglocaledir)"\" $(jsonglib_CFLAGS) $(gthread_CFLAGS) $(gtk_CFLAGS) $(gconf_CFLAGS) $(gio_CFLAGS) $(unique_CFLAGS) $(notify_CFLAGS) -std=gnu99
+INCLUDES = --pedantic -Wall -I.. -O2 -DTRGLICENSE=\""$(trglicense)"\" -DTRGLOCALEDIR=\""$(trglocaledir)"\" $(jsonglib_CFLAGS) $(gthread_CFLAGS) $(gtk_CFLAGS) $(gconf_CFLAGS) $(gio_CFLAGS) $(unique_CFLAGS) $(notify_CFLAGS) $(libproxy_CFLAGS) -std=gnu99
transmission_remote_gtk_SOURCES = main.c \
requests.c \
diff --git a/src/trg-main-window.c b/src/trg-main-window.c
index f61dc75..490f377 100644
--- a/src/trg-main-window.c
+++ b/src/trg-main-window.c
@@ -944,12 +944,7 @@ on_torrent_get(JsonObject * response, int mode, int status, gpointer data)
}
client->failCount = 0;
- stats.downRateTotal = 0;
- stats.upRateTotal = 0;
- stats.seeding = 0;
- stats.down = 0;
- stats.paused = 0;
- stats.count = 0;
+ memset(&stats, 0x0, sizeof(trg_torrent_model_update_stats));
client->updateSerial++;
@@ -1000,12 +995,11 @@ static void on_torrent_get_update(JsonObject * response, int status,
static gboolean trg_update_torrents_timerfunc(gpointer data)
{
TrgMainWindowPrivate *priv = TRG_MAIN_WINDOW_GET_PRIVATE(data);
+ trg_client *client = priv->client;
- if (priv->client->session)
- dispatch_async(priv->client,
- torrent_get(priv->client->
- activeOnlyUpdate ? -2 : -1),
- priv->
+ if (client->session)
+ dispatch_async(client,
+ torrent_get(client->activeOnlyUpdate ? -2 : -1),
client->activeOnlyUpdate ? on_torrent_get_active :
on_torrent_get_update, data);
@@ -1929,11 +1923,10 @@ static GObject *trg_main_window_constructor(GType type,
tray =
gconf_client_get_bool_or_true(priv->client->gconf,
TRG_GCONF_KEY_SYSTEM_TRAY);
- if (tray) {
+ if (tray)
trg_main_window_add_status_icon(self);
- } else {
+ else
priv->statusIcon = NULL;
- }
priv->statusBar = trg_status_bar_new();
g_signal_connect(priv->statusBar, "text-pushed",