summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorGravatar Alan Fitton <ajf@eth0.org.uk>2012-01-18 23:30:02 +0000
committerGravatar Alan Fitton <ajf@eth0.org.uk>2012-01-18 23:30:02 +0000
commitc427fa73c4f7853de992eda9de1c818c2ee525aa (patch)
treec1203a6a808f242038cb063eba4843cf97f2c40f /src/Makefile.am
parent2512c508cb6b8edeefed308a3dce61054d58bb06 (diff)
full and default gtk3 support, almost. the graph is disabled as the drawing api has changed quite a bit. yet another implementation to pass arguments, which made a cleanup of main.c necessary.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 7cf5167..d564181 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -101,6 +101,7 @@ transmission_remote_gtk_SOURCES = main.c \
trg-prefs.c \
trg-destination-combo.c \
remote-exec.c \
+ trg-gtk-app.c \
$(NULL)
transmission_remote_gtk_LDFLAGS = -lm $(jsonglib_LIBS) $(gtk_LIBS) $(gthread_LIBS) $(GEOIP_LIBS) $(gio_LIBS) $(unique_LIBS) $(notify_LIBS) $(libproxy_LIBS) $(libcurl_LIBS) $(libappindicator_LIBS)
@@ -112,7 +113,7 @@ if WIN32
windres $^ -o $@
AM_CFLAGS = -mms-bitfields -mwin32 -mwindows
-transmission_remote_gtk_SOURCES += win32.rc
+transmission_remote_gtk_SOURCES += win32.rc win32-mailslot.c
INCLUDES += -O2
else
%.1: %.pod