summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorGravatar Alan Fitton <ajf@eth0.org.uk>2011-11-27 17:32:00 +0000
committerGravatar Alan Fitton <ajf@eth0.org.uk>2011-11-27 17:32:00 +0000
commit75f7ac97df0be37b83c658d9d6e26aad819ffed5 (patch)
treeb428fd9ccd72ed06273bad151908b4131b437152 /src/Makefile.am
parentc4b85ca0613d484512b7d516d459d00d041d046f (diff)
always use -O2 for the windows build, exclude desktop icons and man pages, request admin rights when the installer is started (to prevent access denied to program files on vista/win7)
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 827e304..f1fc213 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -13,6 +13,7 @@ public_icons = \
hicolor_apps_32x32_transmission-remote-gtk.png \
$(NULL)
+if !WIN32
EXTRA_DIST = transmission-remote-gtk.desktop.in transmission-remote-gtk.pod
CLEANFILES = transmission-remote-gtk.desktop transmission-remote-gtk.1
@@ -20,6 +21,7 @@ man_MANS = transmission-remote-gtk.1
desktopdir = $(datadir)/applications
desktop_DATA = transmission-remote-gtk.desktop
+endif
bin_PROGRAMS = transmission-remote-gtk
INCLUDES = --pedantic -Wall -Wno-format -Wno-overflow -I.. -DTRGLICENSE=\""$(trglicense)"\" $(libcurl_CFLAGS) $(jsonglib_CFLAGS) $(gthread_CFLAGS) $(gtk_CFLAGS) $(gio_CFLAGS) $(unique_CFLAGS) $(notify_CFLAGS) $(libproxy_CFLAGS) -std=gnu99
@@ -84,10 +86,11 @@ if WIN32
AM_CFLAGS = -mms-bitfields -mwin32 -mwindows
transmission_remote_gtk_LDFLAGS += -Wl,--subsystem,windows
transmission_remote_gtk_SOURCES += win32.rc
-endif
+INCLUDES += -O2
%.1: %.pod
pod2man --release="" --center="Transmission Remote GTK" $< > $@
+endif
install-data-local: install-icons update-icon-cache