summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorGravatar Alan Fitton <ajf@eth0.org.uk>2011-09-29 20:54:42 +0000
committerGravatar Alan Fitton <ajf@eth0.org.uk>2011-09-29 20:54:42 +0000
commit37f5bcc29fb404bb1a87d05230ab71c5f31650dc (patch)
tree9d45a3f0d1c284e00b17caf976b0423c965b8719 /src/Makefile.am
parent0a8310af38022a5794c6ec8f0b5a6e745debfdea (diff)
the foundation of remote command execution. still lots of work to do here, but it works for me and seems like a good start.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 13d1680..03b5e2e 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -20,7 +20,7 @@ desktopdir = $(datadir)/applications
desktop_DATA = transmission-remote-gtk.desktop
bin_PROGRAMS = transmission-remote-gtk
-INCLUDES = --pedantic -Wall -Wno-format -I.. -DTRGLICENSE=\""$(trglicense)"\" $(libcurl_CFLAGS) $(jsonglib_CFLAGS) $(gthread_CFLAGS) $(gtk_CFLAGS) $(gio_CFLAGS) $(unique_CFLAGS) $(notify_CFLAGS) $(libproxy_CFLAGS) -std=gnu99
+INCLUDES = --pedantic -Wall -Wno-format -Wno-overflow -I.. -DTRGLICENSE=\""$(trglicense)"\" $(libcurl_CFLAGS) $(jsonglib_CFLAGS) $(gthread_CFLAGS) $(gtk_CFLAGS) $(gio_CFLAGS) $(unique_CFLAGS) $(notify_CFLAGS) $(libproxy_CFLAGS) -std=gnu99
transmission_remote_gtk_SOURCES = main.c \
requests.c \
@@ -70,6 +70,7 @@ transmission_remote_gtk_SOURCES = main.c \
bencode.c \
trg-prefs.c \
trg-destination-combo.c \
+ remote-exec.c \
$(NULL)
transmission_remote_gtk_LDFLAGS = -lm $(jsonglib_LIBS) $(gtk_LIBS) $(gthread_LIBS) $(GEOIP_LIBS) $(gio_LIBS) $(unique_LIBS) $(notify_LIBS) $(libproxy_LIBS) $(libcurl_LIBS)