summaryrefslogtreecommitdiff
path: root/freebsd/Makefile
diff options
context:
space:
mode:
authorGravatar Alan F <ajf@eth0.org.uk>2013-06-22 15:13:10 +0100
committerGravatar Alan F <ajf@eth0.org.uk>2013-06-22 15:13:10 +0100
commitef43c088e5bccf5931c064aaae4006ea2b5bd31e (patch)
treefc89897fb66e9f7a9adce49868234d9b86d0bd74 /freebsd/Makefile
parent2a88e0564611d46b2d03b8e7e37ef3e26f6a55f7 (diff)
freebsd port update from jayp.ml
Diffstat (limited to 'freebsd/Makefile')
-rw-r--r--freebsd/Makefile64
1 files changed, 55 insertions, 9 deletions
diff --git a/freebsd/Makefile b/freebsd/Makefile
index 10f8c20..bea5b11 100644
--- a/freebsd/Makefile
+++ b/freebsd/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= transmission-remote-gtk
-PORTVERSION= 0.5
+PORTVERSION= 1.1.1
CATEGORIES= net-p2p
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
@@ -14,17 +14,63 @@ MAINTAINER= jdm720@gmail.com
COMMENT= GTK app for remote management of Transmission via RPC
LIB_DEPENDS= json-glib-1.0:${PORTSDIR}/devel/json-glib \
- notify.1:${PORTSDIR}/devel/libnotify \
unique-1.0.2:${PORTSDIR}/x11-toolkits/unique \
- curl.6:${PORTSDIR}/ftp/curl
+ curl:${PORTSDIR}/ftp/curl
-RUN_DEPENDS= notification-daemon:${PORTSDIR}/deskutils/notification-daemon
+BUILD_DEPENDS= intltool-update:${PORTSDIR}/textproc/intltool \
+ p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser
-USE_GNOME= glib20 gtk20 gconf2
-GNU_CONFIGURE= yes
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_GNOME= glib20 gconf2
INSTALLS_ICONS= yes
-GCONF_SCHEMAS= transmission-remote-gtk.schemas
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --without-libappindicator
+
+OPTIONS_SINGLE= GTK
+OPTIONS_SINGLE_GTK= GTK2 GTK3
+OPTIONS_DEFINE= NLS GEOIP LIBNOTIFY LIBPROXY
+OPTIONS_DEFAULT= GTK3 NLS LIBNOTIFY
+
+LIBNOTIFY_DESC= Desktop Notifications framework (devel/libnotify)
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MGTK2}
+USE_GNOME+= gtk20
+CONFIGURE_ARGS+=--enable-gtk2
+.else
+USE_GNOME+= gtk30
+.endif
+
+.if ${PORT_OPTIONS:MNLS}
+USES+= gettext
+CONFIGURE_ENV+= DATADIRNAME=share
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB= NLS="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MGEOIP}
+LIB_DEPENDS+= GeoIP:${PORTSDIR}/net/GeoIP
+.else
+CONFIGURE_ARGS+=--without-libgeoip
+.endif
+
+.if ${PORT_OPTIONS:MLIBNOTIFY}
+LIB_DEPENDS+= notify:${PORTSDIR}/devel/libnotify
+.else
+CONFIGURE_ARGS+=--without-libnotify
+.endif
+
+.if ${PORT_OPTIONS:MLIBPROXY}
+LIB_DEPENDS+= libproxy:${PORTSDIR}/net/libproxy
+.else
+CONFIGURE_ARGS+=--without-libproxy
+.endif
-.include <bsd.port.pre.mk>
+MAN1= transmission-remote-gtk.1
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>