summaryrefslogtreecommitdiff
path: root/freebsd/Makefile
diff options
context:
space:
mode:
authorGravatar Benjamin Barenblat <bbaren@mit.edu>2013-07-14 17:14:53 -0700
committerGravatar Benjamin Barenblat <bbaren@mit.edu>2013-07-14 17:14:53 -0700
commit834a3f2151dd8738a1f878489f6207664c4af5aa (patch)
treee67d9dab64d86be62c4c785100339ebb69bf0b99 /freebsd/Makefile
Imported Upstream version 1.1.1upstream/1.1.1
Diffstat (limited to 'freebsd/Makefile')
-rw-r--r--freebsd/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/freebsd/Makefile b/freebsd/Makefile
new file mode 100644
index 0000000..10f8c20
--- /dev/null
+++ b/freebsd/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: transmission-remote-gtk
+# Date created: 22 February 2011
+# Whom: J.D. Morris <jdm720@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= transmission-remote-gtk
+PORTVERSION= 0.5
+CATEGORIES= net-p2p
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+
+MAINTAINER= jdm720@gmail.com
+COMMENT= GTK app for remote management of Transmission via RPC
+
+LIB_DEPENDS= json-glib-1.0:${PORTSDIR}/devel/json-glib \
+ notify.1:${PORTSDIR}/devel/libnotify \
+ unique-1.0.2:${PORTSDIR}/x11-toolkits/unique \
+ curl.6:${PORTSDIR}/ftp/curl
+
+RUN_DEPENDS= notification-daemon:${PORTSDIR}/deskutils/notification-daemon
+
+USE_GNOME= glib20 gtk20 gconf2
+GNU_CONFIGURE= yes
+INSTALLS_ICONS= yes
+GCONF_SCHEMAS= transmission-remote-gtk.schemas
+
+.include <bsd.port.pre.mk>
+
+.include <bsd.port.post.mk>