summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Alan Fitton <ajf@eth0.org.uk>2011-01-30 10:57:07 +0000
committerGravatar Alan Fitton <ajf@eth0.org.uk>2011-01-30 10:57:07 +0000
commiteca35c468094fc6b7177f33ef51fa873eb88e79c (patch)
treefa07fd0ea1db72ff2ad4bd8b04b8e546717f2731 /configure.ac
hello world!
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac43
1 files changed, 43 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..2b9eab6
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,43 @@
+#AC_PREREQ([2.65])
+AC_INIT(transmission-remote-gtk, 0.1, alan@eth0.org.uk)
+AM_INIT_AUTOMAKE(transmission-remote-gtk, 0.1.0)
+AC_OUTPUT(Makefile src/Makefile)
+
+AC_CONFIG_MACRO_DIR([m4])
+AC_CONFIG_SRCDIR([src/main.c])
+AC_CONFIG_HEADERS([config.h])
+
+AC_PROG_CC
+
+# Checks for header files.
+
+AC_CHECK_HEADERS([stdlib.h string.h])
+
+# Checks for programs.
+PKG_CHECK_MODULES([jsonglib], [json-glib-1.0])
+PKG_CHECK_MODULES([gthread], [gthread-2.0])
+PKG_CHECK_MODULES([gconf], [gconf-2.0])
+PKG_CHECK_MODULES([gtk], [gtk+-2.0])
+PKG_CHECK_MODULES([gio], [gio-2.0])
+PKG_CHECK_MODULES([unique], [unique-1.0])
+PKG_CHECK_MODULES([notify], [libnotify])
+
+AC_ARG_WITH([libgeoip], AC_HELP_STRING([--without-libgeoip], [disable GeoIP support]))
+have_libgeoip=no
+if test x$with_libgeoip != xno; then
+ AC_CHECK_HEADER([GeoIP.h],[have_geoip=yes],[have_geoip=no])
+fi
+if test "x$have_geoip" = "xyes"; then
+ AC_DEFINE(HAVE_GEOIP, 1, [GeoIP Support.])
+ GEOIP_LIBS="-lGeoIP"
+ AC_SUBST([GEOIP_LIBS])
+fi
+AM_CONDITIONAL([HAVE_GEOIP], [test "x$have_geoip" = "xyes"])
+
+AM_GCONF_SOURCE_2
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_TYPE_SIZE_T
+AC_FUNC_REALLOC
+
+AC_OUTPUT