summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Alan F <ajf@eth0.org.uk>2014-01-07 09:10:20 +0000
committerGravatar Alan F <ajf@eth0.org.uk>2014-01-07 09:12:35 +0000
commita5fa39775707a998df915abeaae15d0d99f64785 (patch)
treeec23a7f2ece7559b18626a6ef8b3e55fd03d23d9 /configure.ac
parent0b0eb52a5b2c82a4bbcc0d04d523883623124c4f (diff)
remove all support for gtk2
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 8 insertions, 18 deletions
diff --git a/configure.ac b/configure.ac
index 2260c49..0b398ac 100644
--- a/configure.ac
+++ b/configure.ac
@@ -71,8 +71,6 @@ if test "x$have_geoip" = "xyes"; then
fi
AM_CONDITIONAL([HAVE_GEOIP], [test "x$have_geoip" = "xyes"])
-AC_ARG_WITH([libunique], AC_HELP_STRING([--without-libunique], [disable libunique]))
-have_libunique=no
AC_ARG_WITH([libnotify], AC_HELP_STRING([--without-libnotify], [disable libnotify]))
have_libnotify=no
AC_ARG_WITH([libproxy], AC_HELP_STRING([--without-libproxy], [disable libproxy]))
@@ -96,7 +94,6 @@ fi
AC_ARG_ENABLE(gtk3, [AS_HELP_STRING(--enable-gtk3,
[use gtk3 support (now default, left for compatability)])])
-AC_ARG_ENABLE(gtk2, [AS_HELP_STRING(--enable-gtk2,
[use old gtk2 support])])
PKG_CHECK_MODULES([jsonglib], [json-glib-1.0 >= 0.8])
@@ -111,22 +108,15 @@ fi
], [$1])
])
-AC_DEFUN([TRG_GTK2_CONFIGURE], [
-AC_MSG_NOTICE([attempting gtk-2.0 build])
-PKG_CHECK_MODULES([gtk], [gtk+-2.0 >= 2.16])
-if test x$with_libappindicator != xno; then
- PKG_CHECK_MODULES([libappindicator], [appindicator-0.1], AC_DEFINE(HAVE_LIBAPPINDICATOR, 1, [Define if libappindicator is available]), AC_MSG_WARN([Ubuntu Unity users should consider building with libappindicator]))
-fi
-if test x$with_libunique != xno; then
- PKG_CHECK_MODULES([unique], [unique-1.0], AC_DEFINE(HAVE_LIBUNIQUE, 1, [Define if libunique is available]), AC_MSG_WARN([libunique is required for opening torrents on gtk+-2.0. not needed for gtk+-3.0 or win32. ]))
-fi
-])
+#AC_DEFUN([TRG_GTK2_CONFIGURE], [
+#AC_MSG_NOTICE([attempting gtk-2.0 build])
+#PKG_CHECK_MODULES([gtk], [gtk+-2.0 >= 2.16])
+#if test x$with_libappindicator != xno; then
+# PKG_CHECK_MODULES([libappindicator], [appindicator-0.1], AC_DEFINE(HAVE_LIBAPPINDICATOR, 1, [Define if libappindicator is available]), AC_MSG_WARN([Ubuntu Unity users should consider building with libappindicator]))
+#fi
+#])
-if test x$enable_gtk2 = xyes; then
- TRG_GTK2_CONFIGURE([])
-else
- TRG_GTK3_CONFIGURE()
-fi
+TRG_GTK3_CONFIGURE()
PKG_CHECK_MODULES([libcurl], [libcurl])
PKG_CHECK_MODULES([gio], [gio-2.0 >= 2.22])