summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Alan Fitton <ajf@eth0.org.uk>2012-01-19 12:14:16 +0000
committerGravatar Alan Fitton <ajf@eth0.org.uk>2012-01-19 12:14:16 +0000
commit5cb1178c1a453b3dfb6e76e4a758ae8bf5350932 (patch)
treeeeb828f0f3271376d5bebd06ca671cee39480c5d /configure.ac
parent33a6e969bf343ee3e1f771a6ab6a3ab9a14ba19d (diff)
re-enable gtk3 by default, should be picking the right libappindicator now.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 10 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 34be811..d73cf8d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -84,9 +84,6 @@ if test x$with_libproxy != xno; then
PKG_CHECK_MODULES([libproxy], [libproxy-1.0], AC_DEFINE(HAVE_LIBPROXY, 1, [Define if libproxy is available]), AC_MSG_WARN([libproxy is required for HTTP proxy support]))
fi
-if test x$with_libappindicator != xno; then
- PKG_CHECK_MODULES([libappindicator], [appindicator-0.1], AC_DEFINE(HAVE_LIBAPPINDICATOR, 1, [Define if libappindicator is available]), AC_MSG_WARN([Ubuntu Unity users should consider building with libappindicator]))
-fi
AC_ARG_ENABLE(debug, [AS_HELP_STRING(--enable-debug,
[enable debugging])])
@@ -97,13 +94,20 @@ fi
PKG_CHECK_MODULES([jsonglib], [json-glib-1.0 >= 0.8])
PKG_CHECK_MODULES([gthread], [gthread-2.0])
-dnl PKG_CHECK_MODULES([gtk], [gtk+-3.0 >= 3.00], [], [
-dnl AC_MSG_WARN([gtk+-3.0 not found, trying gtk+-2.0])
+PKG_CHECK_MODULES([gtk], [gtk+-3.0 >= 3.00], [
+if test x$with_libappindicator != xno; then
+ PKG_CHECK_MODULES([libappindicator], [appindicator3-0.1], AC_DEFINE(HAVE_LIBAPPINDICATOR, 1, [Define if libappindicator is available]), AC_MSG_WARN([Ubuntu Unity users should consider building with libappindicator]))
+fi
+], [
+AC_MSG_WARN([gtk+-3.0 not found, trying gtk+-2.0])
PKG_CHECK_MODULES([gtk], [gtk+-2.0 >= 2.16])
+if test x$with_libappindicator != xno; then
+ PKG_CHECK_MODULES([libappindicator], [appindicator-0.1], AC_DEFINE(HAVE_LIBAPPINDICATOR, 1, [Define if libappindicator is available]), AC_MSG_WARN([Ubuntu Unity users should consider building with libappindicator]))
+fi
if test x$with_libunique != xno; then
PKG_CHECK_MODULES([unique], [unique-1.0], AC_DEFINE(HAVE_LIBUNIQUE, 1, [Define if libunique is available]), AC_MSG_WARN([libunique is required for opening torrents on gtk+-2.0. not needed for gtk+-3.0 or win32. ]))
fi
-dnl ])
+])
PKG_CHECK_MODULES([libcurl], [libcurl])
PKG_CHECK_MODULES([gio], [gio-2.0 >= 2.22])