summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Alan Fitton <ajf@eth0.org.uk>2011-03-07 20:39:04 +0000
committerGravatar Alan Fitton <ajf@eth0.org.uk>2011-03-07 20:39:04 +0000
commit4073ac25ea4f0b38bef0ad09664e4e66e6fe7f00 (patch)
tree626f8923ef9ad83f2d47b6dd4f6b3994ca563afd /configure.ac
parentecbd6bbb7423bc9b6f329f937bf740b7dc87598d (diff)
support proxy configuration using libproxy (optional). might add a getenv() fallback sometime.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4d4f41c..63522df 100644
--- a/configure.ac
+++ b/configure.ac
@@ -28,6 +28,8 @@ PKG_CHECK_MODULES([gtk], [gtk+-2.0 >= 2.16])
PKG_CHECK_MODULES([gio], [gio-2.0 >= 2.22])
PKG_CHECK_MODULES([unique], [unique-1.0])
PKG_CHECK_MODULES([notify], [libnotify])
+PKG_CHECK_MODULES([libproxy], [libproxy-1.0], AC_DEFINE(HAVE_LIBPROXY, 1, [Define if libproxy is available]), AC_MSG_WARN([libproxy is required for HTTP proxy support]))
+
LIBCURL_CHECK_CONFIG([yes], [7.0], [], [AC_MSG_ERROR(["libcurl not found"])])
AC_ARG_WITH([libgeoip], AC_HELP_STRING([--without-libgeoip], [disable GeoIP support]))