summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Alan F <ajf@eth0.org.uk>2014-02-05 21:13:12 +0000
committerGravatar Alan F <ajf@eth0.org.uk>2014-02-05 21:13:12 +0000
commit37d2c80cfa0bdd8e4af4e2a246c5395bb6681074 (patch)
tree2ef44eeeb22ceb9d2d9afc636dddd7c0aead99d7 /configure.ac
parent98eb06aaeb6ee3d1f1440c3000311e73367778d7 (diff)
the very first steps of an RSS viewer - bit of autotools integration with rss-glib and an empty window.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 40f9545..16e7214 100644
--- a/configure.ac
+++ b/configure.ac
@@ -73,6 +73,8 @@ AM_CONDITIONAL([HAVE_GEOIP], [test "x$have_geoip" = "xyes"])
AC_ARG_WITH([libnotify], AC_HELP_STRING([--without-libnotify], [disable libnotify]))
have_libnotify=no
+AC_ARG_WITH([librssglib], AC_HELP_STRING([--without-rssglib], [disable rssglib support]))
+have_librssglib=no
AC_ARG_WITH([libproxy], AC_HELP_STRING([--without-libproxy], [disable libproxy]))
have_libproxy=no
AC_ARG_WITH([libappindicator], AC_HELP_STRING([--without-libappindicator], [disable libappindicator]))
@@ -82,6 +84,10 @@ if test x$with_libnotify != xno; then
PKG_CHECK_MODULES([notify], [libnotify], AC_DEFINE(HAVE_LIBNOTIFY, 1, [Define if libnotify is available]), AC_MSG_WARN([libnotify is required for popup desktop notifications]))
fi
+if test x$with_librssglib != xno; then
+ PKG_CHECK_MODULES([rssglib], [rss-glib-1.0], AC_DEFINE(HAVE_RSSGLIB, 1, [Define if rss-glib is available]), AC_MSG_WARN([rss-glib is required for RSS viewer functionality]))
+fi
+
if test x$with_libproxy != xno; then
PKG_CHECK_MODULES([libproxy], [libproxy-1.0], AC_DEFINE(HAVE_LIBPROXY, 1, [Define if libproxy is available]), AC_MSG_WARN([libproxy is required for HTTP proxy support]))
fi