summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Alan Fitton <ajf@eth0.org.uk>2011-09-18 21:23:23 +0000
committerGravatar Alan Fitton <ajf@eth0.org.uk>2011-09-18 21:23:23 +0000
commitd453b42def7e0864cbba4489878c351218674dd7 (patch)
tree751c8a07094f2b8f8ee9039596063e1bae60d889
parentc78040dbcfe4c40304944520e0eb4b46dda1e089 (diff)
some win32 build stuff
-rw-r--r--src/Makefile.am21
-rw-r--r--src/main.c5
-rw-r--r--src/transmission_large.icobin0 -> 9662 bytes
-rw-r--r--src/trg-main-window.c5
-rw-r--r--src/trg-remote-prefs-dialog.c2
-rw-r--r--src/win32.rc35
6 files changed, 54 insertions, 14 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index fbd1bb0..63bef54 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -13,11 +13,6 @@ public_icons = \
hicolor_apps_32x32_transmission-remote-gtk.png \
$(NULL)
-#if WIN32
-#AM_CFLAGS = -mms-bitfields
-#AM_LDFLAGS = -Wl,-subsystem,windows
-#endif
-
EXTRA_DIST = transmission-remote-gtk.desktop.in
CLEANFILES = transmission-remote-gtk.desktop
@@ -26,11 +21,7 @@ desktop_DATA = transmission-remote-gtk.desktop
bin_PROGRAMS = transmission-remote-gtk
INCLUDES = --pedantic -Wall -I.. -DTRGLICENSE=\""$(trglicense)"\" $(libcurl_CFLAGS) $(jsonglib_CFLAGS) $(gthread_CFLAGS) $(gtk_CFLAGS) $(gio_CFLAGS) $(unique_CFLAGS) $(notify_CFLAGS) $(libproxy_CFLAGS) -std=gnu99
-
-if WIN32
-INCLUDES += -mms-bitfields -mwin32
-endif
-
+
transmission_remote_gtk_SOURCES = main.c \
requests.c \
json.c \
@@ -82,8 +73,16 @@ transmission_remote_gtk_SOURCES = main.c \
$(NULL)
transmission_remote_gtk_LDFLAGS = -lm -lcurl $(jsonglib_LIBS) $(gtk_LIBS) $(gthread_LIBS) $(GEOIP_LIBS) $(gio_LIBS) $(unique_LIBS) $(notify_LIBS) $(libproxy_LIBS) $(libcurl_LIBS)
+
if WIN32
-transmission_remote_gtk_LDFLAGS += -mwindows
+.rc.o:
+ windres $^ -o $@
+%.o : %.rc
+ windres $^ -o $@
+
+AM_CFLAGS = -mms-bitfields -mwin32 -mwindows
+transmission_remote_gtk_LDFLAGS += -Wl,--subsystem,windows
+transmission_remote_gtk_SOURCES += win32.rc
endif
install-data-local: install-icons update-icon-cache
diff --git a/src/main.c b/src/main.c
index 63e9ca2..3f79971 100644
--- a/src/main.c
+++ b/src/main.c
@@ -38,6 +38,9 @@
#include "trg-client.h"
#ifdef HAVE_LIBUNIQUE
+
+#define TRG_LIBUNIQUE_DOMAIN "uk.org.eth0.trg"
+
enum {
COMMAND_0,
COMMAND_ADD
@@ -116,7 +119,7 @@ int main(int argc, char *argv[])
#ifdef HAVE_LIBUNIQUE
if ((withUnique = g_getenv("TRG_NOUNIQUE") == NULL))
- app = unique_app_new_with_commands("uk.org.eth0.trg", NULL,
+ app = unique_app_new_with_commands(TRG_LIBUNIQUE_DOMAIN, NULL,
"add", COMMAND_ADD, NULL);
if (withUnique && unique_app_is_running(app)) {
diff --git a/src/transmission_large.ico b/src/transmission_large.ico
new file mode 100644
index 0000000..39ddb81
--- /dev/null
+++ b/src/transmission_large.ico
Binary files differ
diff --git a/src/trg-main-window.c b/src/trg-main-window.c
index 7a1998c..710ed4b 100644
--- a/src/trg-main-window.c
+++ b/src/trg-main-window.c
@@ -246,8 +246,6 @@ static void update_selected_torrent_notebook(TrgMainWindow * win, gint mode,
t, mode);
} else if (id < 0) {
trg_main_window_torrent_scrub(win);
- trg_toolbar_torrent_actions_sensitive(priv->toolBar, FALSE);
- trg_menu_bar_torrent_actions_sensitive(priv->menuBar, FALSE);
}
priv->selectedTorrentId = id;
@@ -1125,6 +1123,9 @@ void trg_main_window_torrent_scrub(TrgMainWindow * win) {
trg_general_panel_clear(priv->genDetails);
trg_trackers_model_set_no_selection(TRG_TRACKERS_MODEL
(priv->trackersModel));
+
+ trg_toolbar_torrent_actions_sensitive(priv->toolBar, FALSE);
+ trg_menu_bar_torrent_actions_sensitive(priv->menuBar, FALSE);
}
static void entry_filter_changed_cb(GtkWidget * w, gpointer data) {
diff --git a/src/trg-remote-prefs-dialog.c b/src/trg-remote-prefs-dialog.c
index 3926ff8..7fecd9b 100644
--- a/src/trg-remote-prefs-dialog.c
+++ b/src/trg-remote-prefs-dialog.c
@@ -109,6 +109,7 @@ static void trg_remote_prefs_dialog_get_property(GObject * object,
break;
default:
G_OBJECT_WARN_INVALID_PROPERTY_ID(object, property_id, pspec);
+ break;
}
}
@@ -125,6 +126,7 @@ static void trg_remote_prefs_dialog_set_property(GObject * object,
break;
default:
G_OBJECT_WARN_INVALID_PROPERTY_ID(object, property_id, pspec);
+ break;
}
}
diff --git a/src/win32.rc b/src/win32.rc
new file mode 100644
index 0000000..9fd8d82
--- /dev/null
+++ b/src/win32.rc
@@ -0,0 +1,35 @@
+1 ICON "transmission_large.ico"
+
+// Executable version information.
+1 VERSIONINFO
+ FILEVERSION 1,0,0,0
+ PRODUCTVERSION 1,0,0,0
+ FILEFLAGSMASK 0x17L
+#ifdef DEBUG
+ FILEFLAGS 0x1L
+#else
+ FILEFLAGS 0x0L
+#endif
+ FILEOS 0x4L
+ FILETYPE 0x1L
+ FILESUBTYPE 0x0L
+BEGIN
+ BLOCK "StringFileInfo"
+ BEGIN
+ BLOCK "080904b0"
+ BEGIN
+ VALUE "CompanyName", "eth0.org.uk"
+ VALUE "FileDescription", "Transmission Remote GTK"
+ VALUE "FileVersion", "1, 0, 0, 0"
+ VALUE "InternalName", "transmission-remote-gtk"
+ VALUE "LegalCopyright", "©2011 Alan Fitton"
+ VALUE "OriginalFilename", "transmission-remote-gtk.exe"
+ VALUE "ProductName", "Transmission Remote GTK"
+ VALUE "ProductVersion", "1, 0, 0, 0"
+ END
+ END
+ BLOCK "VarFileInfo"
+ BEGIN
+ VALUE "Translation", 0x809, 1200
+ END
+END \ No newline at end of file