summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Alan Fitton <ajf@eth0.org.uk>2011-10-11 22:10:47 +0000
committerGravatar Alan Fitton <ajf@eth0.org.uk>2011-10-11 22:10:47 +0000
commitac5dce5120ba66cf16774578c1cea5f331df4692 (patch)
tree80592e1f18a50209957793d34fc28c14fffa738c
parent740e695320c9b015fa1dfe203f8e4205024df272 (diff)
make this build on debian squeeze
-rw-r--r--debian/changelog9
-rw-r--r--debian/control4
-rw-r--r--src/trg-about-window.c3
-rw-r--r--src/trg-main-window.c6
-rw-r--r--src/trg-main-window.h4
5 files changed, 19 insertions, 7 deletions
diff --git a/debian/changelog b/debian/changelog
index 76f63d2..72ae95a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,9 +1,18 @@
+transmission-remote-gtk (0.7-1) unstable; urgency=low
+
+ * Execute command support.
+ * Lots of fixes and improvements.
+
+ -- Alan Fitton <alan@eth0.org.uk> Tue, 11 Oct 2011 22:50:00 +0100
+
transmission-remote-gtk (0.5.1-1) unstable; urgency=low
* Use libproxy pkg-config CFLAGS in build, for older versions.
* Fix updates inside the GtkNotebook.
* Fix crash reported by atommixz.
+ -- Alan Fitton <alan@eth0.org.uk> Tue, 11 Oct 2011 22:45:00 +0100
+
transmission-remote-gtk (0.5-1) unstable; urgency=low
* Fixes.
diff --git a/debian/control b/debian/control
index 8f0ff47..91ae50e 100644
--- a/debian/control
+++ b/debian/control
@@ -2,7 +2,7 @@ Source: transmission-remote-gtk
Section: net
Priority: optional
Maintainer: Alan Fitton <alan@eth0.org.uk>
-Build-Depends: debhelper (>= 7.0.50~), autotools-dev, libcurl4-openssl-dev, libgtk2.0-dev (>= 2.16~), libglib2.0-dev (>= 2.22~), libproxy-dev, libnotify-dev, libunique-dev, libjson-glib-dev
+Build-Depends: debhelper (>= 7.0.50~), autotools-dev, libcurl4-openssl-dev, libgtk2.0-dev (>= 2.16~), libglib2.0-dev (>= 2.22~), libproxy-dev, libnotify-dev, libunique-dev, libjson-glib-dev, libgeoip-dev
Standards-Version: 3.8.4
Homepage: http://code.google.com/p/transmission-remote-gtk/
Vcs-Svn: http://transmission-remote-gtk.googlecode.com/svn/trunk/
@@ -10,7 +10,7 @@ Vcs-Browser: http://code.google.com/p/transmission-remote-gtk/source/browse/
Package: transmission-remote-gtk
Architecture: any
-Depends: libgtk2.0-0 (>= 2.16~), libglib2.0-0 (>= 2.22~), libunique-1.0-0, libnotify1, libproxy0, libjson-glib-1.0-0 (>= 0.8~), ${shlibs:Depends}, ${misc:Depends}
+Depends: libgtk2.0-0 (>= 2.16~), libglib2.0-0 (>= 2.22~), libunique-1.0-0, libnotify1, libproxy0, libjson-glib-1.0-0 (>= 0.8~), libgeoip1, ${shlibs:Depends}, ${misc:Depends}
Description: GTK remote control for the Transmission BitTorrent client
transmission-remote-gtk is a GTK application for remote management of
the Transmission BitTorrent client via its RPC interface.
diff --git a/src/trg-about-window.c b/src/trg-about-window.c
index d24cbeb..b73b267 100644
--- a/src/trg-about-window.c
+++ b/src/trg-about-window.c
@@ -35,10 +35,9 @@ GtkWidget *trg_about_window_new(GtkWindow * parent)
gchar *licenseText = NULL;
const gchar *trgAuthors[] = { "Alan Fitton <alan@eth0.org.uk>", NULL };
gchar *licenseFile;
- gchar *moddir;
#ifdef WIN32
- moddir = g_win32_get_package_installation_directory_of_module(NULL);
+ gchar *moddir = g_win32_get_package_installation_directory_of_module(NULL);
licenseFile = g_build_filename(moddir, "..", "COPYING.TXT", NULL);
g_free(moddir);
#else
diff --git a/src/trg-main-window.c b/src/trg-main-window.c
index ce49f01..37e5cfe 100644
--- a/src/trg-main-window.c
+++ b/src/trg-main-window.c
@@ -1342,14 +1342,14 @@ static void clear_filter_entry_cb(GtkWidget * w, gpointer data G_GNUC_UNUSED) {
static gboolean torrent_tv_key_press_event(GtkWidget * w, GdkEventKey * key,
gpointer data) {
TrgMainWindowPrivate *priv = TRG_MAIN_WINDOW_GET_PRIVATE(data);
- if (key->keyval == GDK_KEY_Delete) {
+ if (key->keyval == GDK_Delete) {
if (key->state & GDK_SHIFT_MASK)
delete_cb(w, data);
else
remove_cb(w, data);
- } else if (priv->queuesEnabled && (key->state & GDK_MOD1_MASK) && key->keyval == GDK_KEY_Up) {
+ } else if (priv->queuesEnabled && (key->state & GDK_MOD1_MASK) && key->keyval == GDK_Up) {
up_queue_cb(w, data);
- } else if (priv->queuesEnabled && (key->state & GDK_MOD1_MASK) && key->keyval == GDK_KEY_Down) {
+ } else if (priv->queuesEnabled && (key->state & GDK_MOD1_MASK) && key->keyval == GDK_Down) {
down_queue_cb(w, data);
}
return FALSE;
diff --git a/src/trg-main-window.h b/src/trg-main-window.h
index c9e01a7..683cf35 100644
--- a/src/trg-main-window.h
+++ b/src/trg-main-window.h
@@ -72,5 +72,9 @@ GtkTreeModel *trg_main_window_get_torrent_model(TrgMainWindow * win);
void trg_main_window_notebook_set_visible(TrgMainWindow *win, gboolean visible);
void connect_cb(GtkWidget * w, gpointer data);
+#if !GTK_CHECK_VERSION(2, 21, 1)
+#define gdk_drag_context_get_actions(context) context->actions
+#endif
+
G_END_DECLS
#endif /* MAIN_WINDOW_H_ */