summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Alan Fitton <ajf@eth0.org.uk>2011-09-18 16:22:40 +0000
committerGravatar Alan Fitton <ajf@eth0.org.uk>2011-09-18 16:22:40 +0000
commit52c98d2eb39d00659d051e6e74e0e8a098754163 (patch)
tree2cbf0898eef885bed6de2c66fd7f0ae94e8b5e73
parent79cd86dbfd5b2ea0963c84b48088ec189acfc795 (diff)
forgot to add new m4 macro - acinclude.m4
-rw-r--r--aclocal.m46
-rw-r--r--config.h.in58
-rw-r--r--configure.ac25
-rw-r--r--m4/acinclude.m447
4 files changed, 62 insertions, 74 deletions
diff --git a/aclocal.m4 b/aclocal.m4
index a67ec2a..4325c07 100644
--- a/aclocal.m4
+++ b/aclocal.m4
@@ -13,8 +13,8 @@
m4_ifndef([AC_AUTOCONF_VERSION],
[m4_copy([m4_PACKAGE_VERSION], [AC_AUTOCONF_VERSION])])dnl
-m4_if(m4_defn([AC_AUTOCONF_VERSION]), [2.68],,
-[m4_warning([this file was generated for autoconf 2.68.
+m4_if(m4_defn([AC_AUTOCONF_VERSION]), [2.67],,
+[m4_warning([this file was generated for autoconf 2.67.
You have another version of autoconf. It may work, but is not guaranteed to.
If you have problems, you may need to regenerate the build system entirely.
To do so, use the procedure documented by the package, typically `autoreconf'.])])
@@ -1044,8 +1044,8 @@ AC_SUBST([am__tar])
AC_SUBST([am__untar])
]) # _AM_PROG_TAR
+m4_include([m4/acinclude.m4])
m4_include([m4/intltool.m4])
-m4_include([m4/libcurl.m4])
m4_include([m4/libtool.m4])
m4_include([m4/ltoptions.m4])
m4_include([m4/ltsugar.m4])
diff --git a/config.h.in b/config.h.in
index ddf41fe..ffee3dd 100644
--- a/config.h.in
+++ b/config.h.in
@@ -15,9 +15,6 @@
/* Define to 1 if you have the <inttypes.h> header file. */
#undef HAVE_INTTYPES_H
-/* Define to 1 if you have a functional curl library. */
-#undef HAVE_LIBCURL
-
/* Define if libnotify is available */
#undef HAVE_LIBNOTIFY
@@ -51,56 +48,8 @@
/* Define to 1 if you have the <unistd.h> header file. */
#undef HAVE_UNISTD_H
-/* Defined if libcurl supports AsynchDNS */
-#undef LIBCURL_FEATURE_ASYNCHDNS
-
-/* Defined if libcurl supports IDN */
-#undef LIBCURL_FEATURE_IDN
-
-/* Defined if libcurl supports IPv6 */
-#undef LIBCURL_FEATURE_IPV6
-
-/* Defined if libcurl supports KRB4 */
-#undef LIBCURL_FEATURE_KRB4
-
-/* Defined if libcurl supports libz */
-#undef LIBCURL_FEATURE_LIBZ
-
-/* Defined if libcurl supports NTLM */
-#undef LIBCURL_FEATURE_NTLM
-
-/* Defined if libcurl supports SSL */
-#undef LIBCURL_FEATURE_SSL
-
-/* Defined if libcurl supports SSPI */
-#undef LIBCURL_FEATURE_SSPI
-
-/* Defined if libcurl supports DICT */
-#undef LIBCURL_PROTOCOL_DICT
-
-/* Defined if libcurl supports FILE */
-#undef LIBCURL_PROTOCOL_FILE
-
-/* Defined if libcurl supports FTP */
-#undef LIBCURL_PROTOCOL_FTP
-
-/* Defined if libcurl supports FTPS */
-#undef LIBCURL_PROTOCOL_FTPS
-
-/* Defined if libcurl supports HTTP */
-#undef LIBCURL_PROTOCOL_HTTP
-
-/* Defined if libcurl supports HTTPS */
-#undef LIBCURL_PROTOCOL_HTTPS
-
-/* Defined if libcurl supports LDAP */
-#undef LIBCURL_PROTOCOL_LDAP
-
-/* Defined if libcurl supports TELNET */
-#undef LIBCURL_PROTOCOL_TELNET
-
-/* Defined if libcurl supports TFTP */
-#undef LIBCURL_PROTOCOL_TFTP
+/* gettext catalogs */
+#undef LOCALEDIR
/* Define to the sub-directory in which libtool stores uninstalled libraries.
*/
@@ -136,8 +85,5 @@
/* Version number of package */
#undef VERSION
-/* Define curl_free() as free() if our version of curl lacks curl_free. */
-#undef curl_free
-
/* Define to `unsigned int' if <sys/types.h> does not define. */
#undef size_t
diff --git a/configure.ac b/configure.ac
index e2ce64d..7d8fc4a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,12 +1,5 @@
AC_PREREQ(2.63)
-case "${host}" in
- i[[3456789]]86-mingw32*) WIN32="yes" ;;
- *cygwin*) WIN32="yes" ;;
- *) WIN32="no" ;;
-esac
-dnl AM_CONDITIONAL([WIN32], test "$WIN32" = "yes")
-
AC_INIT(transmission-remote-gtk, 0.6, alan@eth0.org.uk)
AC_CONFIG_SRCDIR(src)
AM_INIT_AUTOMAKE(AC_PACKAGE_NAME, AC_PACKAGE_VERSION)
@@ -26,29 +19,31 @@ IT_PROG_INTLTOOL([0.35.0])
AC_CHECK_HEADERS([stdlib.h string.h])
AC_TYPE_SIZE_T
-OSNAME=`uname -s`
-case "$OSNAME" in
- FreeBSD*)
- CPPFLAGS="$CPPFLAGS -I/usr/local/include"
- ;;
+case "${host_os}" in
+ *mingw32*) WIN32="yes" ;;
+ *cygwin*) WIN32="yes" ;;
+ *freebsd*) WIN32="no";
+ CPPFLAGS="$CPPFLAGS -I/usr/local/include" ;;
+ *) WIN32="no" ;;
esac
-trglocaledir='${prefix}/${DATADIRNAME}/locale'
+AM_CONDITIONAL([WIN32], test "$WIN32" = "yes")
+
trglicense='${docdir}-$(PACKAGE_VERSION)/COPYING'
-AC_SUBST(trglocaledir)
AC_SUBST(trglicense)
GETTEXT_PACKAGE=AC_PACKAGE_NAME
AC_SUBST(GETTEXT_PACKAGE)
AC_DEFINE(GETTEXT_PACKAGE, "AC_PACKAGE_NAME", [foo])
+AC_DEFINE_DIR([LOCALEDIR], [datarootdir/locale], [gettext catalogs])
PKG_CHECK_MODULES([jsonglib], [json-glib-1.0 >= 0.8])
PKG_CHECK_MODULES([gthread], [gthread-2.0])
PKG_CHECK_MODULES([gtk], [gtk+-2.0 >= 2.16])
+PKG_CHECK_MODULES([libcurl], [libcurl])
PKG_CHECK_MODULES([gio], [gio-2.0 >= 2.22])
PKG_CHECK_MODULES([unique], [unique-1.0], AC_DEFINE(HAVE_LIBUNIQUE, 1, [Define if libunique is available]), AC_MSG_WARN([libunique is required for opening torrents]))
PKG_CHECK_MODULES([notify], [libnotify], AC_DEFINE(HAVE_LIBNOTIFY, 1, [Define if libnotify is available]), AC_MSG_WARN([libnotify is required for popup desktop notifications]))
PKG_CHECK_MODULES([libproxy], [libproxy-1.0], AC_DEFINE(HAVE_LIBPROXY, 1, [Define if libproxy is available]), AC_MSG_WARN([libproxy is required for HTTP proxy support]))
-LIBCURL_CHECK_CONFIG([yes], [7.0], [], [AC_MSG_ERROR(["libcurl not found"])])
AC_ARG_WITH([libgeoip], AC_HELP_STRING([--without-libgeoip], [disable GeoIP support]))
have_libgeoip=no
diff --git a/m4/acinclude.m4 b/m4/acinclude.m4
new file mode 100644
index 0000000..f3d8734
--- /dev/null
+++ b/m4/acinclude.m4
@@ -0,0 +1,47 @@
+##### http://autoconf-archive.cryp.to/ac_define_dir.html
+#
+# SYNOPSIS
+#
+# AC_DEFINE_DIR(VARNAME, DIR [, DESCRIPTION])
+#
+# DESCRIPTION
+#
+# This macro sets VARNAME to the expansion of the DIR variable,
+# taking care of fixing up ${prefix} and such.
+#
+# VARNAME is then offered as both an output variable and a C
+# preprocessor symbol.
+#
+# Example:
+#
+# AC_DEFINE_DIR([DATADIR], [datadir], [Where data are placed to.])
+#
+# LAST MODIFICATION
+#
+# 2006-10-13
+#
+# COPYLEFT
+#
+# Copyright (c) 2006 Stepan Kasal <kasal@ucw.cz>
+# Copyright (c) 2006 Andreas Schwab <schwab@suse.de>
+# Copyright (c) 2006 Guido U. Draheim <guidod@gmx.de>
+# Copyright (c) 2006 Alexandre Oliva
+#
+# Copying and distribution of this file, with or without
+# modification, are permitted in any medium without royalty provided
+# the copyright notice and this notice are preserved.
+
+AC_DEFUN([AC_DEFINE_DIR], [
+ prefix_NONE=
+ exec_prefix_NONE=
+ test "x$prefix" = xNONE && prefix_NONE=yes && prefix=$ac_default_prefix
+ test "x$exec_prefix" = xNONE && exec_prefix_NONE=yes && exec_prefix=$prefix
+dnl In Autoconf 2.60, ${datadir} refers to ${datarootdir}, which in turn
+dnl refers to ${prefix}. Thus we have to use `eval' twice.
+ eval ac_define_dir="\"[$]$2\""
+ eval ac_define_dir="\"$ac_define_dir\""
+ AC_SUBST($1, "$ac_define_dir")
+ AC_DEFINE_UNQUOTED($1, "$ac_define_dir", [$3])
+ test "$prefix_NONE" && prefix=NONE
+ test "$exec_prefix_NONE" && exec_prefix=NONE
+])