summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d938afc..4eb0b00 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6,6 +6,13 @@ AC_INIT(rcm, 1.2.1, mburns@thoughtbot.com)
AM_INIT_AUTOMAKE
# Checks for programs.
+case "$host_os" in
+solaris*)
+ AC_PATH_PROGS(POSIX_SHELL, [ksh93 ksh sh])
+ SHELL="$POSIX_SHELL"
+ ;;
+esac
+AC_SUBST([SHELL])
# Checks for libraries.
@@ -16,4 +23,4 @@ AM_INIT_AUTOMAKE
# Checks for library functions.
AM_EXTRA_RECURSIVE_TARGETS([release_build_man_html release_push_man_html release_clean_man_html])
-AC_OUTPUT(Makefile bin/Makefile man/Makefile share/Makefile share/rcm.sh NEWS.md)
+AC_OUTPUT(Makefile bin/Makefile man/Makefile share/Makefile share/rcm.sh NEWS.md bin/lsrc bin/mkrc bin/rcdn bin/rcup)