summaryrefslogtreecommitdiff
path: root/test/mkrc-hostname.t
diff options
context:
space:
mode:
authorGravatar Mike Burns <mike@mike-burns.com>2014-05-05 11:08:02 +0200
committerGravatar Mike Burns <mike@mike-burns.com>2014-05-07 10:43:12 +0200
commit8c26bfec32441830b4a0e5938a6cc7de1a64ff99 (patch)
tree5b22c7195b76f67a79fe4bd763f02faa5bd20e39 /test/mkrc-hostname.t
parentc9d180900a3f8e54b456c9e71bfaac930bbc2478 (diff)
Add a hostname override
Based on issue #82, we now provide `-B` to override the hostname. In particular: - `mkrc -B foo` will enable `-o` but with the hostname set up `foo`. - `lsrc -B foo` will work like normal `lsrc` except it treats `host-foo` as the host-specific directory. - `rcup -B foo` will run a normal `rcup` except `host-foo` is the host-specific directory. - `rcdn -B foo` is just like normal `rcdn`, but with `host-foo` as the host-specific directory. The `HOSTNAME` can also be set in the rcrc(5), and this is overridden by the aforementioned `-B`. While making this change: The `test/Makefile.am` used a mix of tabs and spaces. Since it's a Makefile, replace it all with tabs.
Diffstat (limited to 'test/mkrc-hostname.t')
-rw-r--r--test/mkrc-hostname.t9
1 files changed, 9 insertions, 0 deletions
diff --git a/test/mkrc-hostname.t b/test/mkrc-hostname.t
new file mode 100644
index 0000000..849af75
--- /dev/null
+++ b/test/mkrc-hostname.t
@@ -0,0 +1,9 @@
+ $ . "$TESTDIR/helper.sh"
+
+Able to override the hostname
+
+ $ touch .example
+
+ $ mkrc -B another_thing .example >/dev/null
+
+ $ assert_linked "$HOME/.example" "$HOME/.dotfiles/host-another_thing/example"