summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorGravatar Jarkko Kniivilä <jkniiv@gmail.com>2015-09-05 23:31:42 +0300
committerGravatar Mike Burns <mike@mike-burns.com>2015-11-01 18:59:02 +0100
commitb3f25262c260e81a4bffaa6444b48013f902a04a (patch)
tree8e83ad07b4af379f48de7941779dc600a8f6d8b4 /test/Makefile.am
parent5f592878eed79dd28f9f93418f9456185fd21ac9 (diff)
Fix hooks so that they are run in the directory where they are located
Calls `find(1)` with the `-exec` action just like before but instead of `run_hooks()` letting `find` execute the hook directly it is wrapped in a shell one-liner which changes to the hook's directory and executes the hook with "./" prepended to its basename. These changes allow hooks to refer to dotfiles with relative paths. For instance we can call a Makefile two directories up simply with `make -C ../..`. Also make sure we are compatible with Solaris' Bourne shell and `find(1)`. Closes #150. Closes #149.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 4c5e059..d5aa210 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -27,7 +27,9 @@ TESTS = \
rcup-symlink-dirs.t \
rcup-usage.t \
rcdn-hooks.t \
- rcup-hooks.t
+ rcdn-hooks-run-in-situ.t \
+ rcup-hooks.t \
+ rcup-hooks-run-in-situ.t
dist_check_SCRIPTS = $(TESTS)