summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorGravatar Mike Burns <mike@mike-burns.com>2014-05-05 11:08:02 +0200
committerGravatar Mike Burns <mike@mike-burns.com>2014-05-07 10:43:12 +0200
commit8c26bfec32441830b4a0e5938a6cc7de1a64ff99 (patch)
tree5b22c7195b76f67a79fe4bd763f02faa5bd20e39 /test/Makefile.am
parentc9d180900a3f8e54b456c9e71bfaac930bbc2478 (diff)
Add a hostname override
Based on issue #82, we now provide `-B` to override the hostname. In particular: - `mkrc -B foo` will enable `-o` but with the hostname set up `foo`. - `lsrc -B foo` will work like normal `lsrc` except it treats `host-foo` as the host-specific directory. - `rcup -B foo` will run a normal `rcup` except `host-foo` is the host-specific directory. - `rcdn -B foo` is just like normal `rcdn`, but with `host-foo` as the host-specific directory. The `HOSTNAME` can also be set in the rcrc(5), and this is overridden by the aforementioned `-B`. While making this change: The `test/Makefile.am` used a mix of tabs and spaces. Since it's a Makefile, replace it all with tabs.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am37
1 files changed, 20 insertions, 17 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 9cbc6b2..53dcf0b 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,20 +1,23 @@
TESTS = \
- lsrc-dotfiles-dirs.t \
- lsrc-excludes.t \
- lsrc-hostname.t \
- lsrc-sigils.t \
- lsrc.t \
- lsrc-tags.t \
- lsrc-usage.t \
- mkrc-alternate-dotfiles-dir.t \
- mkrc-copy-file.t \
- mkrc-host-file.t \
- mkrc-simple-output.t \
- mkrc-tagged-file.t \
- mkrc-usage.t \
- rcrc-custom.t \
- rcrc.t \
- rcup-link-files.t \
- rcup-usage.t
+ lsrc-dotfiles-dirs.t \
+ lsrc-excludes.t \
+ lsrc-hostname.t \
+ lsrc-sigils.t \
+ lsrc.t \
+ lsrc-tags.t \
+ lsrc-usage.t \
+ mkrc-alternate-dotfiles-dir.t \
+ mkrc-copy-file.t \
+ mkrc-host-file.t \
+ mkrc-hostname.t \
+ mkrc-simple-output.t \
+ mkrc-tagged-file.t \
+ mkrc-usage.t \
+ rcrc-custom.t \
+ rcrc-hostname.t \
+ rcrc.t \
+ rcup-link-files.t \
+ rcup-hostname.t \
+ rcup-usage.t
LOG_COMPILER = cram