summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar patrick brisbin <pbrisbin@gmail.com>2013-08-23 14:31:32 -0400
committerGravatar Mike Burns <mike@mike-burns.com>2014-04-08 11:37:36 +0200
commita5344a3940f292d8d4f8907f92a54bf726b87e44 (patch)
tree9c6030113ca0db2f83626f4f68857cb0de43f475 /configure.ac
parenta7c2b6bed845b8512e878c992e07841ea9b88462 (diff)
An integration test suite
This test suite uses cram to run integration tests through `/bin/sh`. The tests are all high-level acceptance tests; they should work regardless of the implemention code. To run them, you must first install cram: sudo pip install cram Then the `check` target will run them: make check Failure output should be printed clearly to stdout, but in general: full test output is in `test/test-suite.log` and output specific to a test named `foo.t` is in `foo.t.log`. Tests are now encouraged in `CONTRIBUTING.md` as part of the normal pull request process. This is a TAP-enabled test suite.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5212051..2f1707a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -23,4 +23,4 @@ AC_SUBST([SHELL])
# Checks for library functions.
AM_EXTRA_RECURSIVE_TARGETS([release_build_man_html release_push_man_html release_clean_man_html])
-AC_OUTPUT(Makefile bin/Makefile man/Makefile share/Makefile share/rcm.sh NEWS.md bin/lsrc bin/mkrc bin/rcdn bin/rcup)
+AC_OUTPUT(Makefile bin/Makefile man/Makefile share/Makefile test/Makefile share/rcm.sh NEWS.md bin/lsrc bin/mkrc bin/rcdn bin/rcup)