summaryrefslogtreecommitdiff
path: root/bin/lsrc.in
diff options
context:
space:
mode:
authorGravatar Mike Burns <mike@mike-burns.com>2014-05-05 11:08:02 +0200
committerGravatar Mike Burns <mike@mike-burns.com>2014-05-07 10:43:12 +0200
commit8c26bfec32441830b4a0e5938a6cc7de1a64ff99 (patch)
tree5b22c7195b76f67a79fe4bd763f02faa5bd20e39 /bin/lsrc.in
parentc9d180900a3f8e54b456c9e71bfaac930bbc2478 (diff)
Add a hostname override
Based on issue #82, we now provide `-B` to override the hostname. In particular: - `mkrc -B foo` will enable `-o` but with the hostname set up `foo`. - `lsrc -B foo` will work like normal `lsrc` except it treats `host-foo` as the host-specific directory. - `rcup -B foo` will run a normal `rcup` except `host-foo` is the host-specific directory. - `rcdn -B foo` is just like normal `rcdn`, but with `host-foo` as the host-specific directory. The `HOSTNAME` can also be set in the rcrc(5), and this is overridden by the aforementioned `-B`. While making this change: The `test/Makefile.am` used a mix of tabs and spaces. Since it's a Makefile, replace it all with tabs.
Diffstat (limited to 'bin/lsrc.in')
-rwxr-xr-xbin/lsrc.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/bin/lsrc.in b/bin/lsrc.in
index c5ad700..760d769 100755
--- a/bin/lsrc.in
+++ b/bin/lsrc.in
@@ -227,8 +227,9 @@ handle_command_line() {
local excludes=
local includes=
local symlink_dirs=
+ local hostname=
- while getopts FVqvhI:x:S:t:d: opt; do
+ while getopts FVqvhI:x:B:S:t:d: opt; do
case "$opt" in
F) show_sigils=1;;
h) show_help ;;
@@ -240,11 +241,13 @@ handle_command_line() {
V) version=1;;
x) excludes="$excludes $OPTARG";;
S) symlink_dirs="$symlink_dirs $OPTARG";;
+ B) hostname="$OPTARG";;
esac
done
shift $(($OPTIND-1))
handle_common_flags lsrc $version $verbosity
+ HOSTNAME="$(determine_hostname "$hostname")"
SHOW_SIGILS=$show_sigils
TAGS="${arg_tags:-$TAGS}"
DOTFILES_DIRS="${dotfiles_dirs:-$DOTFILES_DIRS}"