summaryrefslogtreecommitdiff
path: root/arch/PKGBUILD.in
diff options
context:
space:
mode:
authorGravatar Michael Reed <supertron421@gmail.com>2014-06-30 17:03:20 -0400
committerGravatar Mike Burns <mike@mike-burns.com>2014-07-09 10:45:41 +0200
commitff2aa079062c7471c39590abf33d3f38b0c4abc7 (patch)
tree8ab84ff193956feb1cd01f8a8fcc4538b182e7c3 /arch/PKGBUILD.in
parentdb0be686b5cdee270931eb067269484de18b0653 (diff)
PKGBUILD-git improvements
- Remove two configure flags which just caused warnings. - Replace `pkgver` function with a working one. - Explicititly `cd` into `srcdir` before `gitname` as found in `PKGBUILD-git.proto`. - Bump `pkgrel`. - Specify correct package version.
Diffstat (limited to 'arch/PKGBUILD.in')
-rw-r--r--arch/PKGBUILD.in8
1 files changed, 1 insertions, 7 deletions
diff --git a/arch/PKGBUILD.in b/arch/PKGBUILD.in
index 3e197d9..957aca9 100644
--- a/arch/PKGBUILD.in
+++ b/arch/PKGBUILD.in
@@ -1,7 +1,7 @@
# Maintainer: Pat Brisbin <pbrisbin@gmail.com>
pkgname='@PACKAGE@'
pkgver=@PACKAGE_VERSION@
-pkgrel=1
+pkgrel=2
pkgdesc="rc file (dotfile) management"
arch=('any')
url="http://thoughtbot.github.io/@PACKAGE@/"
@@ -12,21 +12,15 @@ sha1sums=('@DIST_SHA@')
build() {
cd "$srcdir/$pkgname-$pkgver"
-
./configure \
- --disable-debug \
- --disable-dependency-tracking \
--disable-silent-rules \
--prefix=/usr
-
make
}
package() {
cd "$srcdir/$pkgname-$pkgver"
-
make DESTDIR="$pkgdir/" install
-
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
}