summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGravatar Mat M <matm@gmx.fr>2019-12-08 00:25:53 +0100
committerGravatar Mike Burns <mburns@thoughtbot.com>2020-01-17 16:46:06 -0500
commitf2fb351c391dca7c188a8623e71519619c2ce9a0 (patch)
tree28efb32af5fa87d62807131e85dbe1529ef23c4a /Makefile.am
parentfb8045f1cf3c8a76cba700d4e0507992be738f89 (diff)
Do not symlink a symlink in mkrc
We have a bug when calling mkrc(1) on a symlink: ```sh mkrc ~/.vimrc # links ~/.vimrc to ~/.dotfiles/vimrc mkrc ~/.vimrc # deletes ~/.dotfiles/vimrc ``` This catches that case ahead of time, preventing the user from running mkrc(1) on a symlink. Fix #144.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 16164d9..4af524d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -24,6 +24,7 @@ TESTS = \
test/mkrc-copy-file.t \
test/mkrc-host-file.t \
test/mkrc-hostname.t \
+ test/mkrc-no-symlinks.t \
test/mkrc-simple-output.t \
test/mkrc-spaces.t \
test/mkrc-symlink-dirs.t \