summaryrefslogtreecommitdiff
path: root/tools/glade/omf-install
diff options
context:
space:
mode:
Diffstat (limited to 'tools/glade/omf-install')
-rw-r--r--tools/glade/omf-install/Makefile.am33
-rw-r--r--tools/glade/omf-install/glade-faq-C.omf15
-rw-r--r--tools/glade/omf-install/glade-faq-ro.omf14
-rw-r--r--tools/glade/omf-install/glade-user-guide-C.omf18
4 files changed, 80 insertions, 0 deletions
diff --git a/tools/glade/omf-install/Makefile.am b/tools/glade/omf-install/Makefile.am
new file mode 100644
index 00000000..72ca9b1d
--- /dev/null
+++ b/tools/glade/omf-install/Makefile.am
@@ -0,0 +1,33 @@
+#
+# Modify the definition of $omf_dest_dir, replacing "gdp-example1" with
+# the name of your package.
+#
+# No other modifications should be necessary.
+#
+# Note that you must configure your package with --localstatedir=/var/lib
+# so that the scrollkeeper-update command below will update the database
+# in the standard scrollkeeper directory.
+#
+# If it is impossible to configure with --localstatedir=/var/lib, then
+# modify the definition of scrollkeeper_localstate_dir so that
+# it points to the correct location. Note that you must still use
+# $(localstatedir) in this or when people build RPMs it will update
+# the real database on their system instead of the one under RPM_BUILD_ROOT.
+
+omf_dest_dir=$(datadir)/omf/glade-2
+scrollkeeper_localstate_dir = $(localstatedir)/scrollkeeper
+
+install-data-local:
+ $(mkinstalldirs) $(DESTDIR)$(omf_dest_dir)
+ -for file in $(srcdir)/*.omf; do \
+ $(INSTALL_DATA) $(srcdir)/$$file $(DESTDIR)$(omf_dest_dir); \
+ done
+ -scrollkeeper-update -p $(scrollkeeper_localstate_dir)
+
+uninstall-local:
+ -for file in $(srcdir)/*.omf; do \
+ basefile=`basename $$file`; \
+ rm -f $(omf_dest_dir)/$$basefile; \
+ done
+ -rmdir $(omf_dest_dir)
+ -scrollkeeper-update -p $(scrollkeeper_localstate_dir)
diff --git a/tools/glade/omf-install/glade-faq-C.omf b/tools/glade/omf-install/glade-faq-C.omf
new file mode 100644
index 00000000..625d1d16
--- /dev/null
+++ b/tools/glade/omf-install/glade-faq-C.omf
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8" ?>
+<omf>
+ <resource>
+ <creator>damon@gnome.org (Damon Chaplin)</creator>
+ <title>Glade FAQ</title>
+ <date>2004-03-17</date>
+ <subject category="GNOME|Applications|Programming" />
+ <description>Frequently Asked Questions list for the Glade application.</description>
+ <format mime="text/xml" dtd="-//OASIS//DTD DocBook XML V4.1.2//EN" />
+ <identifier url="file://usr/local/share/gnome/help/glade-2/C/glade-faq.xml" />
+ <language code="C" />
+ <relation seriesid="2619c82a-a636-11d6-8522-d29c286dcc64" />
+ <rights type="GNU FDL" license.version="1.1" holder="Damon Chaplin" />
+ </resource>
+</omf>
diff --git a/tools/glade/omf-install/glade-faq-ro.omf b/tools/glade/omf-install/glade-faq-ro.omf
new file mode 100644
index 00000000..f980301a
--- /dev/null
+++ b/tools/glade/omf-install/glade-faq-ro.omf
@@ -0,0 +1,14 @@
+<?xml version="1.0" standalone="no" ?>
+<!DOCTYPE omf PUBLIC "-//OMF//DTD Scrollkeeper OMF Variant V1.0//EN" "http://scrollkeeper.sourceforge.net/dtds/scrollkeeper-omf-1.0/scrollkeeper-omf.dtd">
+<omf>
+ <resource>
+ <creator>Damon Chaplin</creator>
+ <title>Glade FAQ</title>
+ <date>2002</date>
+ <subject category="GNOME|Development" />
+ <format mime="text/xml" />
+ <identifier url="file://usr/local/share/gnome/help/glade-2/ro/glade-faq.xml" />
+ <language code="ro" />
+ <relation seriesid="2619c82a-a636-11d6-8522-d29c286dcc64" />
+ </resource>
+</omf>
diff --git a/tools/glade/omf-install/glade-user-guide-C.omf b/tools/glade/omf-install/glade-user-guide-C.omf
new file mode 100644
index 00000000..6dda00e2
--- /dev/null
+++ b/tools/glade/omf-install/glade-user-guide-C.omf
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8" ?>
+<omf>
+ <resource>
+ <creator>docs@gnome.org (GDP)</creator>
+ <maintainer>docs@gnome.org (GDP)</maintainer>
+ <title>Glade Manual V2.1</title>
+ <date>2004-06-17</date>
+ <version identifier="2.1" date="2004-06-17" description="Updated for GNOME 2.6, program version 2.0.0" />
+ <subject category="GNOME|Applications|Programming" />
+ <description>User manual for the Glade application.</description>
+ <type>user&apos;s guide</type>
+ <format mime="text/xml" dtd="-//OASIS//DTD DocBook XML V4.1.2//EN" />
+ <identifier url="file://usr/local/share/gnome/help/glade-2/C/glade-user-guide.xml" />
+ <language code="C" />
+ <relation seriesid="15c7f60c-3093-11d8-924d-b89741557cdb" />
+ <rights type="GNU FDL" license.version="1.1" holder="Sun Microsystems, Michael Vance" />
+ </resource>
+</omf>