summaryrefslogtreecommitdiff
path: root/tools/glade/examples/editor/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'tools/glade/examples/editor/configure.in')
-rw-r--r--tools/glade/examples/editor/configure.in31
1 files changed, 31 insertions, 0 deletions
diff --git a/tools/glade/examples/editor/configure.in b/tools/glade/examples/editor/configure.in
new file mode 100644
index 00000000..43574665
--- /dev/null
+++ b/tools/glade/examples/editor/configure.in
@@ -0,0 +1,31 @@
+dnl Process this file with autoconf to produce a configure script.
+
+AC_INIT(configure.in)
+AM_INIT_AUTOMAKE(glade-editor, 0.1)
+AM_CONFIG_HEADER(config.h)
+AM_MAINTAINER_MODE
+
+AC_ISC_POSIX
+AC_PROG_CC
+AM_PROG_CC_STDC
+AC_HEADER_STDC
+
+pkg_modules="gtk+-2.0 >= 2.0.0"
+PKG_CHECK_MODULES(PACKAGE, [$pkg_modules])
+AC_SUBST(PACKAGE_CFLAGS)
+AC_SUBST(PACKAGE_LIBS)
+
+GETTEXT_PACKAGE=glade-editor
+AC_SUBST(GETTEXT_PACKAGE)
+AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE")
+
+dnl Add the languages which your application supports here.
+ALL_LINGUAS=""
+AM_GLIB_GNU_GETTEXT
+
+AC_OUTPUT([
+Makefile
+src/Makefile
+po/Makefile.in
+])
+