summaryrefslogtreecommitdiff
path: root/tools/glade/examples/editor/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tools/glade/examples/editor/Makefile.am')
-rw-r--r--tools/glade/examples/editor/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/tools/glade/examples/editor/Makefile.am b/tools/glade/examples/editor/Makefile.am
new file mode 100644
index 00000000..37b60f39
--- /dev/null
+++ b/tools/glade/examples/editor/Makefile.am
@@ -0,0 +1,30 @@
+## Process this file with automake to produce Makefile.in
+
+SUBDIRS = src po
+
+EXTRA_DIST = \
+ autogen.sh \
+ editor.glade \
+ editor.gladep
+
+install-data-local:
+ @$(NORMAL_INSTALL)
+ if test -d $(srcdir)/pixmaps; then \
+ $(mkinstalldirs) $(DESTDIR)$(pkgdatadir)/pixmaps; \
+ for pixmap in $(srcdir)/pixmaps/*; do \
+ if test -f $$pixmap; then \
+ $(INSTALL_DATA) $$pixmap $(DESTDIR)$(pkgdatadir)/pixmaps; \
+ fi \
+ done \
+ fi
+
+dist-hook:
+ if test -d pixmaps; then \
+ mkdir $(distdir)/pixmaps; \
+ for pixmap in pixmaps/*; do \
+ if test -f $$pixmap; then \
+ cp -p $$pixmap $(distdir)/pixmaps; \
+ fi \
+ done \
+ fi
+