summaryrefslogtreecommitdiff
path: root/sid/sidplay-libs-2.1.0/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'sid/sidplay-libs-2.1.0/configure.ac')
-rw-r--r--sid/sidplay-libs-2.1.0/configure.ac62
1 files changed, 62 insertions, 0 deletions
diff --git a/sid/sidplay-libs-2.1.0/configure.ac b/sid/sidplay-libs-2.1.0/configure.ac
new file mode 100644
index 00000000..e85773a6
--- /dev/null
+++ b/sid/sidplay-libs-2.1.0/configure.ac
@@ -0,0 +1,62 @@
+AC_INIT(Makefile.am)
+
+#Variables
+resid=resid-0.13
+pwd=`pwd`
+builders='${libdir}'/sidplay/builders
+ac_configure_args="$ac_configure_args --disable-library-checks"
+
+# Setup paths
+test ! -r "resid" && ln -sf "$resid" "resid"
+test ! -r "unix" && ln -sf libsidplay/unix unix
+
+AC_CONFIG_AUX_DIR(unix)
+AM_INIT_AUTOMAKE(sidplay-libs,2.1.0)
+
+if ! test -r "builders/Makefile.am"; then
+echo "Generating builder Makefile.am..."
+cat >>builders/Makefile.am <<EOF
+SUBDIRS = resid-builder
+EOF
+automake -a
+fi
+
+cd $pwd/libsidplay
+if ! eval ./configure $ac_configure_args \
+--with-sidbuilders=$builders;
+then
+exit
+fi
+
+cd "$pwd/resid"
+if ! eval ./configure $ac_configure_args \
+--disable-resid-install;
+then
+exit
+fi
+
+cd $pwd/builders/resid-builder
+if ! eval ./configure $ac_configure_args \
+--with-sidplay2-includes=$pwd/libsidplay/include \
+--with-sidplay2-library=$pwd/libsidplay/src \
+--with-resid-includes=$pwd/resid \
+--with-resid-library=$pwd/resid \
+--libdir=$builders;
+then
+exit
+fi
+
+cd $pwd/libsidutils
+if ! eval ./configure $ac_configure_args \
+--with-sidplay2-includes=$pwd/libsidplay/include \
+--with-sidplay2-library=$pwd/libsidplay/src;
+then
+exit
+fi
+
+cd $pwd
+
+AC_OUTPUT(
+Makefile \
+builders/Makefile \
+)